summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-03-17 15:02:02 -0400
committerJason R. Coombs <jaraco@jaraco.com>2018-03-17 15:02:02 -0400
commite553c1576b7db2f2cd867461856eda71177cd731 (patch)
tree1f1b53684133e5445364e6d650855de7ed1e55f8 /setup.py
parent139db200fdaba09dfacd0c59ba6e1bff664c4ebf (diff)
parentcd31f81d564c1cd93c7cbf0b1b19c034e310ad52 (diff)
downloadpytest-runner-e553c1576b7db2f2cd867461856eda71177cd731.tar.gz
Merge https://github.com/jaraco/skeleton
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b96db52..9320edb 100644
--- a/setup.py
+++ b/setup.py
@@ -35,15 +35,22 @@ params = dict(
],
extras_require={
'testing': [
+ # upstream
'pytest>=2.8',
'pytest-sugar>=0.9.1',
'collective.checkdocs',
+ 'pytest-flake8',
+
+ # local
'pytest-virtualenv',
],
'docs': [
+ # upstream
'sphinx',
'jaraco.packaging>=3.2',
'rst.linker>=1.9',
+
+ # local
],
},
setup_requires=[