summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-09-17 20:11:24 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-09-17 20:11:24 -0400
commit598c66dc21bdf87bf73d4e10ba988c3734b1e500 (patch)
treecde8231a6d5378a91a86e2670b6c88b41c9d6dd0 /setup.py
parentecd62723bcb95755c91c1bf819d582ffe3bececa (diff)
parent03c1cc86843bcfbb6c2a9366d285427ac006aeee (diff)
downloadpytest-runner-598c66dc21bdf87bf73d4e10ba988c3734b1e500.tar.gz
Merge with latest skeleton
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 3ce3e6e..f1d1d7b 100644
--- a/setup.py
+++ b/setup.py
@@ -12,9 +12,7 @@ with io.open('README.rst', encoding='utf-8') as readme:
needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
pytest_runner = ['pytest_runner'] if needs_pytest else []
-needs_sphinx = set(['release', 'build_sphinx', 'upload_docs']).intersection(sys.argv)
-sphinx = ['sphinx', 'rst.linker'] if needs_sphinx else []
-needs_wheel = set(['release', 'bdist_wheel']).intersection(sys.argv)
+needs_wheel = set(['release', 'bdist_wheel', 'dists']).intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
name = 'pytest-runner'
@@ -36,7 +34,7 @@ setup_params = dict(
},
setup_requires=[
'setuptools_scm>=1.9',
- ] + pytest_runner + sphinx + wheel,
+ ] + pytest_runner + wheel,
tests_require=[
'pytest>=2.8',
],