summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-09-22 10:50:07 -0500
committerJason R. Coombs <jaraco@jaraco.com>2016-09-22 10:50:07 -0500
commit750a2b38964adc868b1a7f4570afa1532418b12c (patch)
tree5fef50d62dd7a3679c30c797f1f4373d0f0a95a5 /setup.py
parent03c1cc86843bcfbb6c2a9366d285427ac006aeee (diff)
downloadpytest-runner-750a2b38964adc868b1a7f4570afa1532418b12c.tar.gz
Use tox instead of pytest-runner
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 1f815f2..ec848c1 100644
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,6 @@ import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
-pytest_runner = ['pytest_runner'] if needs_pytest else []
needs_wheel = {'release', 'bdist_wheel', 'dists'}.intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
@@ -35,10 +33,7 @@ setup_params = dict(
},
setup_requires=[
'setuptools_scm>=1.9',
- ] + pytest_runner + wheel,
- tests_require=[
- 'pytest>=2.8',
- ],
+ ] + wheel,
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",