summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2015-03-01 10:28:07 -0500
committerJason R. Coombs <jaraco@jaraco.com>2015-03-01 10:28:07 -0500
commit8cac0b2cb71073568c5a6e6187136837c3ded7f5 (patch)
tree579c62c3eed0acec67156296078ab81f9d344030 /setup.py
downloadpytest-runner-8cac0b2cb71073568c5a6e6187136837c3ded7f5.tar.gz
Adding project skeleton
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ac40a89
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+#!/usr/bin/env python
+# Generated by jaraco.develop 2.14
+# https://pypi.python.org/pypi/jaraco.develop
+
+import io
+import sys
+
+import setuptools
+
+with io.open('README.txt', encoding='utf-8') as readme:
+ long_description = readme.read()
+
+needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
+pytest_runner = ['pytest_runner'] if needs_pytest else []
+needs_sphinx = {'release', 'build_sphinx', 'upload_docs'}.intersection(sys.argv)
+sphinx = ['sphinx'] if needs_sphinx else []
+
+setup_params = dict(
+ name='pytest-runner',
+ use_scm_version=True,
+ author="Jason R. Coombs",
+ author_email="jaraco@jaraco.com",
+ description="pytest-runner",
+ long_description=long_description,
+ url="https://bitbucket.org/jaraco/pytest-runner",
+ packages=setuptools.find_packages(),
+ namespace_packages=[''],
+ install_requires=[
+ ],
+ setup_requires=[
+ 'setuptools_scm',
+ ] + pytest_runner + sphinx,
+ tests_require=[
+ 'pytest',
+ ],
+ license='MIT',
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ ],
+)
+if __name__ == '__main__':
+ setuptools.setup(**setup_params)