summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-04-02 22:44:23 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-04-02 22:44:23 -0400
commitbbf28379f4d8cb8c308dfa36605ef63c9031a207 (patch)
treeb2826607481ca0e5fb317d841b91af2bef82ef71 /setup.py
parent24c1111b4f4702a241ab57bddef8e7989842b9a2 (diff)
parent01e953bac9ac132fba90550492ee9f7eedfce7e0 (diff)
downloadpytest-runner-bbf28379f4d8cb8c308dfa36605ef63c9031a207.tar.gz
Merge with skeleton. Fixes #15.2.7.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 36ce32d..a81681d 100644
--- a/setup.py
+++ b/setup.py
@@ -13,19 +13,22 @@ with io.open('README.rst', encoding='utf-8') as readme:
needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
pytest_runner = ['pytest_runner'] if needs_pytest else []
needs_sphinx = set(['release', 'build_sphinx', 'upload_docs']).intersection(sys.argv)
-sphinx = ['sphinx'] if needs_sphinx else []
+sphinx = ['sphinx', 'rst.linker'] if needs_sphinx else []
needs_wheel = set(['release', 'bdist_wheel']).intersection(sys.argv)
wheel = ['wheel'] if needs_wheel else []
+name = 'pytest-runner'
+description = 'Invoke py.test as distutils command with dependency resolution'
+
setup_params = dict(
- name='pytest-runner',
+ name=name,
use_scm_version=True,
author="Jason R. Coombs",
author_email="jaraco@jaraco.com",
- description="Invoke py.test as distutils command with dependency "
- "resolution.",
+ description=description or name,
long_description=long_description,
- url="https://github.com/pytest-dev/pytest-runner",
+ url="https://github.com/pytest-dev/" + name,
+ namespace_packages=name.split('.')[:-1],
py_modules=['ptr'],
install_requires=[
],