summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-01-20 11:19:29 -0500
committerJason R. Coombs <jaraco@jaraco.com>2017-01-20 11:19:29 -0500
commitce5a9260dd3821270d0000b1a15aa73b65838789 (patch)
tree23616b05ed43da7ddd75c31898e90f209160a89c /setup.py
parentdc04e99cfb8c23747b91ff9155b45074149faae7 (diff)
parent9f6eea591eaae483be11d13ebad06958a6a1e2c8 (diff)
downloadpytest-runner-ce5a9260dd3821270d0000b1a15aa73b65838789.tar.gz
Merge skeleton
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 3 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 3600f92..f587434 100644
--- a/setup.py
+++ b/setup.py
@@ -3,20 +3,16 @@
# Project skeleton maintained at https://github.com/jaraco/skeleton
import io
-import sys
import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-needs_wheel = set(['release', 'bdist_wheel', 'dists']).intersection(sys.argv)
-wheel = ['wheel'] if needs_wheel else []
-
name = 'pytest-runner'
description = 'Invoke py.test as distutils command with dependency resolution'
-setup_params = dict(
+params = dict(
name=name,
use_scm_version=True,
author="Jason R. Coombs",
@@ -32,7 +28,7 @@ setup_params = dict(
},
setup_requires=[
'setuptools_scm>=1.15.0',
- ] + wheel,
+ ],
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
@@ -50,4 +46,4 @@ setup_params = dict(
},
)
if __name__ == '__main__':
- setuptools.setup(**setup_params)
+ setuptools.setup(**params)