summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-02-13 12:56:17 -0500
committerJason R. Coombs <jaraco@jaraco.com>2016-02-13 12:56:17 -0500
commite416f2f01a6ce7e7bb3fbd1df05de70111f1107d (patch)
tree241e8d6058ab78ac14709ed7e461c447229496cd /setup.py
parentaf4f2b73aaf7e47078c770074c8cf7f64528aac2 (diff)
parent6d571b47f84e8ee87decbaffbd577c5f556efb4b (diff)
downloadpytest-runner-e416f2f01a6ce7e7bb3fbd1df05de70111f1107d.tar.gz
Merge with latest skeleton
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py108
1 files changed, 56 insertions, 52 deletions
diff --git a/setup.py b/setup.py
index 1216ab5..0cb6716 100644
--- a/setup.py
+++ b/setup.py
@@ -1,52 +1,56 @@
-#!/usr/bin/env python
-# Generated by jaraco.develop 2.14
-# https://pypi.python.org/pypi/jaraco.develop
-
-import io
-import sys
-
-import setuptools
-
-with io.open('README.txt', encoding='utf-8') as readme:
- long_description = readme.read()
-
-needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
-pytest_runner = ['pytest-runner'] if needs_pytest else []
-needs_sphinx = set(['release', 'build_sphinx', 'upload_docs']).intersection(sys.argv)
-sphinx = ['sphinx'] if needs_sphinx else []
-
-setup_params = dict(
- name='pytest-runner',
- use_scm_version=True,
- author="Jason R. Coombs",
- author_email="jaraco@jaraco.com",
- description="Invoke py.test as distutils command with dependency "
- "resolution.",
- long_description=long_description,
- url="https://bitbucket.org/pytest-dev/pytest-runner",
- py_modules=['ptr'],
- entry_points = {
- 'distutils.commands': [
- 'ptr = ptr:PyTest',
- 'pytest = ptr:PyTest',
- ],
- },
- install_requires=[
- ],
- setup_requires=[
- 'setuptools_scm',
- ] + pytest_runner + sphinx,
- tests_require=[
- 'pytest',
- ],
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: MIT License",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- ],
-)
-if __name__ == '__main__':
- setuptools.setup(**setup_params)
+#!/usr/bin/env python
+# Generated by jaraco.develop 2.27.1
+# https://pypi.python.org/pypi/jaraco.develop
+
+import io
+import sys
+
+import setuptools
+
+with io.open('README.rst', encoding='utf-8') as readme:
+ long_description = readme.read()
+
+needs_pytest = set(['pytest', 'test']).intersection(sys.argv)
+pytest_runner = ['pytest_runner'] if needs_pytest else []
+needs_sphinx = set(['release', 'build_sphinx', 'upload_docs']).intersection(sys.argv)
+sphinx = ['sphinx'] if needs_sphinx else []
+needs_wheel = set(['release', 'bdist_wheel']).intersection(sys.argv)
+wheel = ['wheel'] if needs_wheel else []
+
+setup_params = dict(
+ name='pytest-runner',
+ use_scm_version=True,
+ author="Jason R. Coombs",
+ author_email="jaraco@jaraco.com",
+ description="Invoke py.test as distutils command with dependency "
+ "resolution.",
+ long_description=long_description,
+ url="https://bitbucket.org/pytest-dev/pytest-runner",
+ py_modules=['ptr'],
+ install_requires=[
+ ],
+ extras_require={
+ },
+ setup_requires=[
+ 'setuptools_scm>=1.9',
+ ] + pytest_runner + sphinx + wheel,
+ tests_require=[
+ 'pytest>=2.8',
+ ],
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ ],
+ entry_points = {
+ 'distutils.commands': [
+ 'ptr = ptr:PyTest',
+ 'pytest = ptr:PyTest',
+ ],
+ },
+)
+if __name__ == '__main__':
+ setuptools.setup(**setup_params)