summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-09-03 12:04:32 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-09-03 12:18:30 -0400
commit18c23373216a57bd0301a07601120aecd95906f4 (patch)
tree27dbf3111ecfe8546caf99695b953a357127a1f7 /setup.py
parentac7c1ae23d83bad87b67e72b7a4b33bc760c2908 (diff)
parent250cb960021233160e78a6f2c2780cfc1c964b9c (diff)
downloadpytest-runner-18c23373216a57bd0301a07601120aecd95906f4.tar.gz
Merge https://github.com/jaraco/skeleton2.12
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 25 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f587434..1e95a0e 100644
--- a/setup.py
+++ b/setup.py
@@ -11,6 +11,11 @@ with io.open('README.rst', encoding='utf-8') as readme:
name = 'pytest-runner'
description = 'Invoke py.test as distutils command with dependency resolution'
+nspkg_technique = 'native'
+"""
+Does this package use "native" namespace packages or
+pkg_resources "managed" namespace packages?
+"""
params = dict(
name=name,
@@ -20,11 +25,29 @@ params = dict(
description=description or name,
long_description=long_description,
url="https://github.com/pytest-dev/" + name,
- namespace_packages=name.split('.')[:-1],
+ namespace_packages=(
+ name.split('.')[:-1] if nspkg_technique == 'managed'
+ else []
+ ),
py_modules=['ptr'],
+ python_requires='>=2.6',
install_requires=[
],
extras_require={
+ 'testing': [
+ 'pytest>=2.8',
+ 'pytest-sugar',
+ 'pytest-virtualenv',
+ ],
+ 'testing:python_version=="2.6"': [
+ # undeclared dependency of pytest-virtualenv
+ 'importlib',
+ ],
+ 'docs': [
+ 'sphinx',
+ 'jaraco.packaging>=3.2',
+ 'rst.linker>=1.9',
+ ],
},
setup_requires=[
'setuptools_scm>=1.15.0',
@@ -38,7 +61,7 @@ params = dict(
"Programming Language :: Python :: 3",
"Framework :: Pytest",
],
- entry_points = {
+ entry_points={
'distutils.commands': [
'ptr = ptr:PyTest',
'pytest = ptr:PyTest',