summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-10-27 09:55:12 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-10-27 09:55:12 -0400
commit59735f374dd0085e54eed110c4979a1bff2ed53e (patch)
treebda7d2112d8f1a94cfbd13fb3d33108bb79ceb94 /tests
parent932c91db97fe8a93ce54f4f4e04e2fd1e28b2275 (diff)
parent2c970db6066919e1120dfadc259cf7f433290445 (diff)
downloadpytest-runner-59735f374dd0085e54eed110c4979a1bff2ed53e.tar.gz
Merge branch 'master' into feature/drop-py26
Diffstat (limited to 'tests')
-rw-r--r--tests/test_ptr.py14
1 files changed, 13 insertions, 1 deletions
diff --git a/tests/test_ptr.py b/tests/test_ptr.py
index aac5e75..fcbf0c5 100644
--- a/tests/test_ptr.py
+++ b/tests/test_ptr.py
@@ -2,6 +2,7 @@ from __future__ import unicode_literals
import io
import os
+import shutil
import sys
import tarfile
import textwrap
@@ -87,6 +88,13 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
</body></html>
'''
).format(dist_sdist=dist_sdist))
+ # Move barbazquux1 out of the index.
+ shutil.move(index_dir / 'barbazquux1', venv.workspace)
+ barbazquux1_link = (
+ 'file://' + str(venv.workspace.abspath())
+ + '/barbazquux1/barbazquux1-0.1.tar.gz'
+ + '#egg=barbazquux1-0.1'
+ )
# Prepare fake project.
project_dir = (venv.workspace / 'project-0.1').mkdir()
with open(project_dir / 'setup.py', 'w') as fp:
@@ -96,6 +104,9 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
setup(
name='project',
version='0.1',
+ dependency_links = [
+ {barbazquux1_link!r},
+ ],
setup_requires=[
'pytest-runner',
],
@@ -112,7 +123,8 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
'extra': 'barbazquux5',
}}
)
- ''').format(sys_platform=sys.platform))
+ ''').format(sys_platform=sys.platform,
+ barbazquux1_link=barbazquux1_link))
with open(project_dir / 'setup.cfg', 'w') as fp:
fp.write(DALS(
'''