summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml17
1 files changed, 13 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 6e5e969..7ff32e9 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,8 +1,17 @@
sudo: false
language: python
python:
- - 2.7
- - 3.5
+- 2.7
+- 3.5
script:
- - pip install -U pytest
- - python setup.py test
+- pip install -U pytest
+- python setup.py test
+deploy:
+ provider: pypi
+ on:
+ tags: true
+ all_branches: true
+ user: jaraco
+ # supply password with `travis encrypt --add deploy.password`
+ distributions: release
+ python: 3.5