summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--pytest-runner/__init__.py0
-rw-r--r--pytest-runner/command.py (renamed from command.py)0
-rw-r--r--setup.py22
3 files changed, 22 insertions, 0 deletions
diff --git a/pytest-runner/__init__.py b/pytest-runner/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/pytest-runner/__init__.py
diff --git a/command.py b/pytest-runner/command.py
index a9481a7..a9481a7 100644
--- a/command.py
+++ b/pytest-runner/command.py
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d33b450
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+# Generated by jaraco.develop (https://bitbucket.org/jaraco/jaraco.develop)
+import setuptools
+
+setup_params = dict(
+ name='pytest-runner',
+ use_hg_version=True,
+ author="Jason R. Coombs",
+ author_email="jaraco@jaraco.com",
+ url="https://bitbucket.org/jaraco/pytest-runner",
+ packages=setuptools.find_packages(),
+ zip_safe=True,
+ entry_points = {
+ 'distutils.commands':
+ ['test = pytest-runner.command:PyTest'],
+ },
+ setup_requires=[
+ 'hgtools',
+ ],
+)
+if __name__ == '__main__':
+ setuptools.setup(**setup_params)