summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.flake87
-rw-r--r--.pre-commit-config.yaml5
-rw-r--r--.travis.yml32
-rw-r--r--README.rst4
-rw-r--r--docs/conf.py52
-rw-r--r--ptr.py367
-rw-r--r--pyproject.toml6
-rw-r--r--pytest.ini9
-rw-r--r--setup.cfg48
-rw-r--r--setup.py74
-rw-r--r--skeleton.md129
-rw-r--r--tests/test_ptr.py74
-rw-r--r--tox.ini21
13 files changed, 491 insertions, 337 deletions
diff --git a/.flake8 b/.flake8
index 04d2d97..790c109 100644
--- a/.flake8
+++ b/.flake8
@@ -1,10 +1,9 @@
[flake8]
+max-line-length = 88
ignore =
- # Allow tabs for indentation
- W191
- # Workaround for https://github.com/PyCQA/pycodestyle/issues/836
- E117
# W503 violates spec https://github.com/PyCQA/pycodestyle/issues/513
W503
# W504 has issues https://github.com/OCA/maintainer-quality-tools/issues/545
W504
+ # Black creates whitespace before colon
+ E203
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 0000000..922d942
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,5 @@
+repos:
+- repo: https://github.com/ambv/black
+ rev: 18.9b0
+ hooks:
+ - id: black
diff --git a/.travis.yml b/.travis.yml
index e570814..cb30c47 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,10 @@
-dist: trusty
-sudo: false
+dist: xenial
language: python
python:
- 2.7
-- &latest_py3 3.6
-- nightly
+- 3.6
+- &latest_py3 3.7
jobs:
fast_finish: true
@@ -13,23 +12,22 @@ jobs:
- stage: deploy
if: tag IS present
python: *latest_py3
- install: skip
- script: skip
- deploy:
- provider: pypi
- on:
- tags: true
- all_branches: true
- user: jaraco
- password:
- secure: lZfYQx0ZrCf2FJ+348etKWfzTySB3BZYGd0ce5RFHN2BppcdkONyJfTs4rgdrFEn/WtOaKV3SkJYR09xvlr+4kbLibg7fXhueqZt0ZkhRBnoDE4SxCjICyFCmisG6O3zkrVosizch70/0MqseNanhgXOPhd5llCfQHIqLsa145BG4hM5kxAHPO3Rz2/HCObOTPe4HKj93RAK7lPIMZVN6omcWoG6ZB0QqK+i3LTUtmJ3gE6q/iHk3VF9cJs8xtn3hdo++Lhrboa2NIqf6fl8oxR1C24Wh8vBQ69uTNjmVnDFYMulTs5475jjgDBXPPgVz3CAqYAy/PI+NPw59ebK8MzlaMRK/h/xSrdhxW6K3WbBL71Dn2UGuejXHFC3IuCI832xwkuEupOcGLWz4r2uBnhbgXF63vZ2gYPqrCGHxvDpbtllTVyEeebP8BnFzZttxSn9rbhTP1O9Dn/9tRko8WskyXIR+/2JOA9KP5uT47yeHoFBBUS0GB1XdkGhBrJfQx2LhfHuI6bpzosMiMfJrVNZEg8k0I9XA0uwxDgZrdqKGMKBR6233MXiJg8NyUPRInCRGth4rufcq6kn+wsT9RvuSt9XOhGiYLwChjvHexUXrLGBgupu0Y80Oqcp3YkDG3WHUX++Z2zJSQovrb4BMdKS6Y4usQ8Df5SklIpMCf0=
- distributions: dists
- skip_cleanup: true
- skip_upload_docs: true
+ before_script: skip
+ env:
+ - TWINE_USERNAME=jaraco
+ # TWINE_PASSWORD
+ - secure: Ud9UIW92Gdg2eZpuA9UwC0YjanRaD9CTpKXoLT9Cjp5C2rufwiZd8K/LXK6P6x/nVyLJ8+7HR+TQTReoO2c6kt2vVkA9i3KE2N/bD9PXQo80NwMWepFkRBJh28M9x3fGeQTYRegx3cUWVh4gaa9ZFZBwSjnRZvTtvQh1WhEvHWFzBkb/8CkifmQPmdEYT4D0JBskBAtC295G6p3FukcSdzKlDljY1G4m2ZDqUepYC0R0mr5vDz9JxbJ4axxUvvy7hVd5vrI6xshUc1lRYGocfTcc0IBCq8kw2nzG+KK06axBGFMqCioT4ohUFWB1sLj8pbwpc0uCLtjIBE9OnFZFt52ZKuJcJFAZwiQ3Mxnpg+WC39mrD+jAyIOBDIp/5+2JDCPGyD2i8RuBJrt1CzMqno+Y0K5H2g3XD7E+pclFgyj21JhqUzRAvYE9gbA6561PyFoi+JEFbk5eiNYRdWjp/7XJJSNWB3tDC6hbEAIGQLY2ZcZjnURKN92AC7361negFgwEaaCRUeHx3g7k/wrR/16Po3kFFb/vzQ4ygMxH0lVzzQ0M81121zl4fJPzs/klnBVcf4YOph8Gm6md3ARJu7CKDV2bt2Qr/TObroYFe/flAWZ+KM5DTFqd1dediYrrdVMDuvwSUn1kDjpRnrcI/v0MeT1Vx5v2yekS8iucwCY=
+ - TOX_TESTENV_PASSENV="TWINE_USERNAME TWINE_PASSWORD"
+ script: tox -e release
cache: pip
install:
- pip install tox tox-venv
+before_script:
+ # Disable IPv6. Ref travis-ci/travis-ci#8361
+ - if [ "${TRAVIS_OS_NAME}" == "linux" ]; then
+ sudo sh -c 'echo 0 > /proc/sys/net/ipv6/conf/all/disable_ipv6';
+ fi
script: tox
diff --git a/README.rst b/README.rst
index 80247ce..879e84a 100644
--- a/README.rst
+++ b/README.rst
@@ -6,6 +6,10 @@
.. image:: https://img.shields.io/travis/pytest-dev/pytest-runner/master.svg
:target: https://travis-ci.org/pytest-dev/pytest-runner
+.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
+ :target: https://github.com/ambv/black
+ :alt: Code style: Black
+
.. .. image:: https://img.shields.io/appveyor/ci/pytest-dev/pytest-runner/master.svg
.. :target: https://ci.appveyor.com/project/pytest-dev/pytest-runner/branch/master
diff --git a/docs/conf.py b/docs/conf.py
index c82b462..40166c5 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -1,36 +1,30 @@
#!/usr/bin/env python3
# -*- coding: utf-8 -*-
-extensions = [
- 'sphinx.ext.autodoc',
- 'jaraco.packaging.sphinx',
- 'rst.linker',
-]
+extensions = ['sphinx.ext.autodoc', 'jaraco.packaging.sphinx', 'rst.linker']
-master_doc = 'index'
+master_doc = "index"
link_files = {
- '../CHANGES.rst': dict(
- using=dict(
- GH='https://github.com',
- ),
- replace=[
- dict(
- pattern=r'(Issue )?#(?P<issue>\d+)',
- url='{package_url}/issues/{issue}',
- ),
- dict(
- pattern=r'^(?m)((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n',
- with_scm='{text}\n{rev[timestamp]:%d %b %Y}\n',
- ),
- dict(
- pattern=r'PEP[- ](?P<pep_number>\d+)',
- url='https://www.python.org/dev/peps/pep-{pep_number:0>4}/',
- ),
- dict(
- pattern=r'Setuptools #(?P<setuptools_issue>\d+)',
- url='https://github.com/pypa/setuptools/issues/{setuptools_issue}/',
- ),
- ],
- ),
+ '../CHANGES.rst': dict(
+ using=dict(GH='https://github.com'),
+ replace=[
+ dict(
+ pattern=r'(Issue #|\B#)(?P<issue>\d+)',
+ url='{package_url}/issues/{issue}',
+ ),
+ dict(
+ pattern=r'^(?m)((?P<scm_version>v?\d+(\.\d+){1,2}))\n[-=]+\n',
+ with_scm='{text}\n{rev[timestamp]:%d %b %Y}\n',
+ ),
+ dict(
+ pattern=r'PEP[- ](?P<pep_number>\d+)',
+ url='https://www.python.org/dev/peps/pep-{pep_number:0>4}/',
+ ),
+ dict(
+ pattern=r'Setuptools #(?P<setuptools_issue>\d+)',
+ url='https://github.com/pypa/setuptools' '/issues/{setuptools_issue}/',
+ ),
+ ],
+ )
}
diff --git a/ptr.py b/ptr.py
index 75fa993..f3952e8 100644
--- a/ptr.py
+++ b/ptr.py
@@ -11,10 +11,10 @@ import itertools as _itertools
import warnings as _warnings
try:
- # ensure that map has the same meaning on Python 2
- from future_builtins import map
+ # ensure that map has the same meaning on Python 2
+ from future_builtins import map
except ImportError:
- pass
+ pass
import pkg_resources
import setuptools.command.test as orig
@@ -23,181 +23,200 @@ from setuptools import Distribution
@_contextlib.contextmanager
def _save_argv(repl=None):
- saved = _sys.argv[:]
- if repl is not None:
- _sys.argv[:] = repl
- try:
- yield saved
- finally:
- _sys.argv[:] = saved
+ saved = _sys.argv[:]
+ if repl is not None:
+ _sys.argv[:] = repl
+ try:
+ yield saved
+ finally:
+ _sys.argv[:] = saved
class CustomizedDist(Distribution):
- allow_hosts = None
- index_url = None
-
- def fetch_build_egg(self, req):
- """ Specialized version of Distribution.fetch_build_egg
- that respects respects allow_hosts and index_url. """
- from setuptools.command.easy_install import easy_install
- dist = Distribution({'script_args': ['easy_install']})
- dist.parse_config_files()
- opts = dist.get_option_dict('easy_install')
- keep = (
- 'find_links', 'site_dirs', 'index_url', 'optimize',
- 'site_dirs', 'allow_hosts'
- )
- for key in list(opts):
- if key not in keep:
- del opts[key] # don't use any other settings
- if self.dependency_links:
- links = self.dependency_links[:]
- if 'find_links' in opts:
- links = opts['find_links'][1].split() + links
- opts['find_links'] = ('setup', links)
- if self.allow_hosts:
- opts['allow_hosts'] = ('test', self.allow_hosts)
- if self.index_url:
- opts['index_url'] = ('test', self.index_url)
- install_dir_func = getattr(self, 'get_egg_cache_dir', _os.getcwd)
- install_dir = install_dir_func()
- cmd = easy_install(
- dist, args=["x"], install_dir=install_dir,
- exclude_scripts=True,
- always_copy=False, build_directory=None, editable=False,
- upgrade=False, multi_version=True, no_report=True, user=False
- )
- cmd.ensure_finalized()
- return cmd.easy_install(req)
+ allow_hosts = None
+ index_url = None
+
+ def fetch_build_egg(self, req):
+ """ Specialized version of Distribution.fetch_build_egg
+ that respects respects allow_hosts and index_url. """
+ from setuptools.command.easy_install import easy_install
+
+ dist = Distribution({'script_args': ['easy_install']})
+ dist.parse_config_files()
+ opts = dist.get_option_dict('easy_install')
+ keep = (
+ 'find_links',
+ 'site_dirs',
+ 'index_url',
+ 'optimize',
+ 'site_dirs',
+ 'allow_hosts',
+ )
+ for key in list(opts):
+ if key not in keep:
+ del opts[key] # don't use any other settings
+ if self.dependency_links:
+ links = self.dependency_links[:]
+ if 'find_links' in opts:
+ links = opts['find_links'][1].split() + links
+ opts['find_links'] = ('setup', links)
+ if self.allow_hosts:
+ opts['allow_hosts'] = ('test', self.allow_hosts)
+ if self.index_url:
+ opts['index_url'] = ('test', self.index_url)
+ install_dir_func = getattr(self, 'get_egg_cache_dir', _os.getcwd)
+ install_dir = install_dir_func()
+ cmd = easy_install(
+ dist,
+ args=["x"],
+ install_dir=install_dir,
+ exclude_scripts=True,
+ always_copy=False,
+ build_directory=None,
+ editable=False,
+ upgrade=False,
+ multi_version=True,
+ no_report=True,
+ user=False,
+ )
+ cmd.ensure_finalized()
+ return cmd.easy_install(req)
class PyTest(orig.test):
- """
- >>> import setuptools
- >>> dist = setuptools.Distribution()
- >>> cmd = PyTest(dist)
- """
-
- user_options = [
- ('extras', None, "Install (all) setuptools extras when running tests"),
- ('index-url=', None, "Specify an index url from which to retrieve "
- "dependencies"),
- ('allow-hosts=', None, "Whitelist of comma-separated hosts to allow "
- "when retrieving dependencies"),
- ('addopts=', None, "Additional options to be passed verbatim to the "
- "pytest runner")
- ]
-
- def initialize_options(self):
- self.extras = False
- self.index_url = None
- self.allow_hosts = None
- self.addopts = []
- self.ensure_setuptools_version()
-
- @staticmethod
- def ensure_setuptools_version():
- """
- Due to the fact that pytest-runner is often required (via
- setup-requires directive) by toolchains that never invoke
- it (i.e. they're only installing the package, not testing it),
- instead of declaring the dependency in the package
- metadata, assert the requirement at run time.
- """
- pkg_resources.require('setuptools>=27.3')
-
- def finalize_options(self):
- if self.addopts:
- self.addopts = _shlex.split(self.addopts)
-
- @staticmethod
- def marker_passes(marker):
- """
- Given an environment marker, return True if the marker is valid
- and matches this environment.
- """
- return (
- not marker
- or not pkg_resources.invalid_marker(marker)
- and pkg_resources.evaluate_marker(marker)
- )
-
- def install_dists(self, dist):
- """
- Extend install_dists to include extras support
- """
- return _itertools.chain(
- orig.test.install_dists(dist),
- self.install_extra_dists(dist),
- )
-
- def install_extra_dists(self, dist):
- """
- Install extras that are indicated by markers or
- install all extras if '--extras' is indicated.
- """
- extras_require = dist.extras_require or {}
-
- spec_extras = (
- (spec.partition(':'), reqs)
- for spec, reqs in extras_require.items()
- )
- matching_extras = (
- reqs
- for (name, sep, marker), reqs in spec_extras
- # include unnamed extras or all if self.extras indicated
- if (not name or self.extras)
- # never include extras that fail to pass marker eval
- and self.marker_passes(marker)
- )
- results = list(map(dist.fetch_build_eggs, matching_extras))
- return _itertools.chain.from_iterable(results)
-
- @staticmethod
- def _warn_old_setuptools():
- msg = (
- "pytest-runner will stop working on this version of setuptools; "
- "please upgrade to setuptools 30.4 or later or pin to "
- "pytest-runner < 5."
- )
- ver_str = pkg_resources.get_distribution('setuptools').version
- ver = pkg_resources.parse_version(ver_str)
- if ver < pkg_resources.parse_version('30.4'):
- _warnings.warn(msg)
-
- def run(self):
- """
- Override run to ensure requirements are available in this session (but
- don't install them anywhere).
- """
- self._warn_old_setuptools()
- dist = CustomizedDist()
- for attr in 'allow_hosts index_url'.split():
- setattr(dist, attr, getattr(self, attr))
- for attr in (
- 'dependency_links install_requires '
- 'tests_require extras_require '
- ).split():
- setattr(dist, attr, getattr(self.distribution, attr))
- installed_dists = self.install_dists(dist)
- if self.dry_run:
- self.announce('skipping tests (dry run)')
- return
- paths = map(_operator.attrgetter('location'), installed_dists)
- with self.paths_on_pythonpath(paths):
- with self.project_on_sys_path():
- return self.run_tests()
-
- @property
- def _argv(self):
- return ['pytest'] + self.addopts
-
- def run_tests(self):
- """
- Invoke pytest, replacing argv. Return result code.
- """
- with _save_argv(_sys.argv[:1] + self.addopts):
- result_code = __import__('pytest').main()
- if result_code:
- raise SystemExit(result_code)
+ """
+ >>> import setuptools
+ >>> dist = setuptools.Distribution()
+ >>> cmd = PyTest(dist)
+ """
+
+ user_options = [
+ ('extras', None, "Install (all) setuptools extras when running tests"),
+ (
+ 'index-url=',
+ None,
+ "Specify an index url from which to retrieve " "dependencies",
+ ),
+ (
+ 'allow-hosts=',
+ None,
+ "Whitelist of comma-separated hosts to allow "
+ "when retrieving dependencies",
+ ),
+ (
+ 'addopts=',
+ None,
+ "Additional options to be passed verbatim to the " "pytest runner",
+ ),
+ ]
+
+ def initialize_options(self):
+ self.extras = False
+ self.index_url = None
+ self.allow_hosts = None
+ self.addopts = []
+ self.ensure_setuptools_version()
+
+ @staticmethod
+ def ensure_setuptools_version():
+ """
+ Due to the fact that pytest-runner is often required (via
+ setup-requires directive) by toolchains that never invoke
+ it (i.e. they're only installing the package, not testing it),
+ instead of declaring the dependency in the package
+ metadata, assert the requirement at run time.
+ """
+ pkg_resources.require('setuptools>=27.3')
+
+ def finalize_options(self):
+ if self.addopts:
+ self.addopts = _shlex.split(self.addopts)
+
+ @staticmethod
+ def marker_passes(marker):
+ """
+ Given an environment marker, return True if the marker is valid
+ and matches this environment.
+ """
+ return (
+ not marker
+ or not pkg_resources.invalid_marker(marker)
+ and pkg_resources.evaluate_marker(marker)
+ )
+
+ def install_dists(self, dist):
+ """
+ Extend install_dists to include extras support
+ """
+ return _itertools.chain(
+ orig.test.install_dists(dist), self.install_extra_dists(dist)
+ )
+
+ def install_extra_dists(self, dist):
+ """
+ Install extras that are indicated by markers or
+ install all extras if '--extras' is indicated.
+ """
+ extras_require = dist.extras_require or {}
+
+ spec_extras = (
+ (spec.partition(':'), reqs) for spec, reqs in extras_require.items()
+ )
+ matching_extras = (
+ reqs
+ for (name, sep, marker), reqs in spec_extras
+ # include unnamed extras or all if self.extras indicated
+ if (not name or self.extras)
+ # never include extras that fail to pass marker eval
+ and self.marker_passes(marker)
+ )
+ results = list(map(dist.fetch_build_eggs, matching_extras))
+ return _itertools.chain.from_iterable(results)
+
+ @staticmethod
+ def _warn_old_setuptools():
+ msg = (
+ "pytest-runner will stop working on this version of setuptools; "
+ "please upgrade to setuptools 30.4 or later or pin to "
+ "pytest-runner < 5."
+ )
+ ver_str = pkg_resources.get_distribution('setuptools').version
+ ver = pkg_resources.parse_version(ver_str)
+ if ver < pkg_resources.parse_version('30.4'):
+ _warnings.warn(msg)
+
+ def run(self):
+ """
+ Override run to ensure requirements are available in this session (but
+ don't install them anywhere).
+ """
+ self._warn_old_setuptools()
+ dist = CustomizedDist()
+ for attr in 'allow_hosts index_url'.split():
+ setattr(dist, attr, getattr(self, attr))
+ for attr in (
+ 'dependency_links install_requires ' 'tests_require extras_require '
+ ).split():
+ setattr(dist, attr, getattr(self.distribution, attr))
+ installed_dists = self.install_dists(dist)
+ if self.dry_run:
+ self.announce('skipping tests (dry run)')
+ return
+ paths = map(_operator.attrgetter('location'), installed_dists)
+ with self.paths_on_pythonpath(paths):
+ with self.project_on_sys_path():
+ return self.run_tests()
+
+ @property
+ def _argv(self):
+ return ['pytest'] + self.addopts
+
+ def run_tests(self):
+ """
+ Invoke pytest, replacing argv. Return result code.
+ """
+ with _save_argv(_sys.argv[:1] + self.addopts):
+ result_code = __import__('pytest').main()
+ if result_code:
+ raise SystemExit(result_code)
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3afc8c3
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,6 @@
+[build-system]
+requires = ["setuptools>=34.4", "wheel", "setuptools_scm>=1.15"]
+build-backend = "setuptools.build_meta"
+
+[tool.black]
+skip-string-normalization = true
diff --git a/pytest.ini b/pytest.ini
index 0ba22c3..10681ad 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,4 +1,11 @@
[pytest]
norecursedirs=dist build .tox .eggs
-addopts=--doctest-modules --flake8
+addopts=--doctest-modules --flake8 --black
doctest_optionflags=ALLOW_UNICODE ELLIPSIS
+filterwarnings=
+ ignore:Possible nested set::pycodestyle:113
+ ignore:Using or importing the ABCs::flake8:410
+ # workaround for https://sourceforge.net/p/docutils/bugs/348/
+ ignore:'U' mode is deprecated::docutils.io
+ # workaround for https://gitlab.com/pycqa/flake8/issues/275
+ ignore:You passed a bytestring as `filenames`.::flake8
diff --git a/setup.cfg b/setup.cfg
index 378a8e4..31585db 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,9 +1,49 @@
-[aliases]
-release = dists upload
-dists = clean --all sdist bdist_wheel
-
[bdist_wheel]
universal = 1
[metadata]
license_file = LICENSE
+name = pytest-runner
+author = Jason R. Coombs
+author_email = jaraco@jaraco.com
+description = Invoke py.test as distutils command with dependency resolution
+long_description = file:README.rst
+url = https://github.com/pytest-dev/pytest-runner/
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Intended Audience :: Developers
+ License :: OSI Approved :: MIT License
+ Programming Language :: Python :: 2.7
+ Programming Language :: Python :: 3
+ Framework :: Pytest
+
+[options]
+py_modules = ptr
+python_requires = >=2.7
+install_requires =
+ # setuptools 27.3 is required at run time
+setup_requires = setuptools_scm >= 1.15.0
+
+[options.extras_require]
+testing =
+ # upstream
+ pytest >= 3.5, !=3.7.3
+ pytest-checkdocs
+ pytest-flake8
+ pytest-black-multipy
+
+ # local
+ pytest-virtualenv
+
+docs =
+ # upstream
+ sphinx
+ jaraco.packaging >= 3.2
+ rst.linker >= 1.9
+
+ # local
+
+[options.entry_points]
+distutils.commands =
+ ptr = ptr:PyTest
+ pytest = ptr:PyTest
diff --git a/setup.py b/setup.py
index b72262c..827e955 100644
--- a/setup.py
+++ b/setup.py
@@ -1,76 +1,6 @@
#!/usr/bin/env python
-# Project skeleton maintained at https://github.com/jaraco/skeleton
-
-import io
-
import setuptools
-with io.open('README.rst', encoding='utf-8') as readme:
- long_description = readme.read()
-
-name = 'pytest-runner'
-description = 'Invoke py.test as distutils command with dependency resolution'
-nspkg_technique = 'native'
-"""
-Does this package use "native" namespace packages or
-pkg_resources "managed" namespace packages?
-"""
-
-params = dict(
- name=name,
- use_scm_version=True,
- author="Jason R. Coombs",
- author_email="jaraco@jaraco.com",
- description=description or name,
- long_description=long_description,
- url="https://github.com/pytest-dev/" + name,
- namespace_packages=(
- name.split('.')[:-1] if nspkg_technique == 'managed'
- else []
- ),
- py_modules=['ptr'],
- python_requires='>=2.7,!=3.0,!=3.1',
- install_requires=[
- # setuptools 27.3 is required at run time
- ],
- extras_require={
- 'testing': [
- # upstream
- 'pytest>=2.8',
- 'pytest-sugar>=0.9.1',
- 'collective.checkdocs',
- 'pytest-flake8',
-
- # local
- 'pytest-virtualenv',
- ],
- 'docs': [
- # upstream
- 'sphinx',
- 'jaraco.packaging>=3.2',
- 'rst.linker>=1.9',
-
- # local
- ],
- },
- setup_requires=[
- 'setuptools_scm>=1.15.0',
- ],
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: MIT License",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Framework :: Pytest",
- ],
- entry_points={
- 'distutils.commands': [
- 'ptr = ptr:PyTest',
- 'pytest = ptr:PyTest',
- ],
- },
-)
-if __name__ == '__main__':
- setuptools.setup(**params)
+if __name__ == "__main__":
+ setuptools.setup(use_scm_version=True)
diff --git a/skeleton.md b/skeleton.md
new file mode 100644
index 0000000..7249407
--- /dev/null
+++ b/skeleton.md
@@ -0,0 +1,129 @@
+# Overview
+
+This project is merged with [skeleton](https://github.com/jaraco/skeleton). What is skeleton? It's the scaffolding of a Python project jaraco [introduced in his blog](https://blog.jaraco.com/a-project-skeleton-for-python-projects/). It seeks to provide a means to re-use techniques and inherit advances when managing projects for distribution.
+
+## An SCM Managed Approach
+
+While maintaining dozens of projects in PyPI, jaraco derives best practices for project distribution and publishes them in the [skeleton repo](https://github.com/jaraco/skeleton), a git repo capturing the evolution and culmination of these best practices.
+
+It's intended to be used by a new or existing project to adopt these practices and honed and proven techniques. Adopters are encouraged to use the project directly and maintain a small deviation from the technique, make their own fork for more substantial changes unique to their environment or preferences, or simply adopt the skeleton once and abandon it thereafter.
+
+The primary advantage to using an SCM for maintaining these techniques is that those tools help facilitate the merge between the template and its adopting projects.
+
+Another advantage to using an SCM-managed approach is that tools like GitHub recognize that a change in the skeleton is the _same change_ across all projects that merge with that skeleton. Without the ancestry, with a traditional copy/paste approach, a [commit like this](https://github.com/jaraco/skeleton/commit/12eed1326e1bc26ce256e7b3f8cd8d3a5beab2d5) would produce notifications in the upstream project issue for each and every application, but because it's centralized, GitHub provides just the one notification when the change is added to the skeleton.
+
+# Usage
+
+## new projects
+
+To use skeleton for a new project, simply pull the skeleton into a new project:
+
+```
+$ git init my-new-project
+$ cd my-new-project
+$ git pull gh://jaraco/skeleton
+```
+
+Now customize the project to suit your individual project needs.
+
+## existing projects
+
+If you have an existing project, you can still incorporate the skeleton by merging it into the codebase.
+
+```
+$ git merge skeleton --allow-unrelated-histories
+```
+
+The `--allow-unrelated-histories` is necessary because the history from the skeleton was previously unrelated to the existing codebase. Resolve any merge conflicts and commit to the master, and now the project is based on the shared skeleton.
+
+## Updating
+
+Whenever a change is needed or desired for the general technique for packaging, it can be made in the skeleton project and then merged into each of the derived projects as needed, recommended before each release. As a result, features and best practices for packaging are centrally maintained and readily trickle into a whole suite of packages. This technique lowers the amount of tedious work necessary to create or maintain a project, and coupled with other techniques like continuous integration and deployment, lowers the cost of creating and maintaining refined Python projects to just a few, familiar git operations.
+
+Thereafter, the target project can make whatever customizations it deems relevant to the scaffolding. The project may even at some point decide that the divergence is too great to merit renewed merging with the original skeleton. This approach applies maximal guidance while creating minimal constraints.
+
+# Features
+
+The features/techniques employed by the skeleton include:
+
+- PEP 517/518 based build relying on setuptools as the build tool
+- setuptools declarative configuration using setup.cfg
+- tox for running tests
+- A README.rst as reStructuredText with some popular badges, but with readthedocs and appveyor badges commented out
+- A CHANGES.rst file intended for publishing release notes about the project
+- Use of [black](https://black.readthedocs.io/en/stable/) for code formatting (disabled on unsupported Python 3.5 and earlier)
+
+## Packaging Conventions
+
+A pyproject.toml is included to enable PEP 517 and PEP 518 compatibility and declares the requirements necessary to build the project on setuptools (a minimum version compatible with setup.cfg declarative config).
+
+The setup.cfg file implements the following features:
+
+- Assumes universal wheel for release
+- Advertises the project's LICENSE file (MIT by default)
+- Reads the README.rst file into the long description
+- Some common Trove classifiers
+- Includes all packages discovered in the repo
+- Data files in the package are also included (not just Python files)
+- Declares the required Python versions
+- Declares install requirements (empty by default)
+- Declares setup requirements for legacy environments
+- Supplies two 'extras':
+ - testing: requirements for running tests
+ - docs: requirements for building docs
+ - these extras split the declaration into "upstream" (requirements as declared by the skeleton) and "local" (those specific to the local project); these markers help avoid merge conflicts
+- Placeholder for defining entry points
+
+Additionally, the setup.py file declares `use_scm_version` which relies on [setuptools_scm](https://pypi.org/project/setuptools_scm) to do two things:
+
+- derive the project version from SCM tags
+- ensure that all files committed to the repo are automatically included in releases
+
+## Running Tests
+
+The skeleton assumes the developer has [tox](https://pypi.org/project/tox) installed. The developer is expected to run `tox` to run tests on the current Python version using [pytest](https://pypi.org/project/pytest).
+
+Other environments (invoked with `tox -e {name}`) supplied include:
+
+ - a `build-docs` environment to build the documentation
+ - a `release` environment to publish the package to PyPI
+
+A pytest.ini is included to define common options around running tests. In particular:
+
+- rely on default test discovery in the current directory
+- avoid recursing into common directories not containing tests
+- run doctests on modules and invoke flake8 tests
+- in doctests, allow unicode literals and regular literals to match, allowing for doctests to run on Python 2 and 3. Also enable ELLIPSES, a default that would be undone by supplying the prior option.
+- filters out known warnings caused by libraries/functionality included by the skeleton
+
+Relies a .flake8 file to correct some default behaviors:
+
+- disable mutually incompatible rules W503 and W504
+- support for black format
+
+## Continuous Integration
+
+The project is pre-configured to run tests in [Travis-CI](https://travis-ci.org) (.travis.yml). Any new project must be enabled either through their web site or with the `travis enable` command. In addition to running tests, an additional deploy stage is configured to automatically release tagged commits. The username and password for PyPI must be configured for each project using the `travis` command and only after the travis project is created. As releases are cut with [twine](https://pypi.org/project/twine), the two values are supplied through the `TWINE_USERNAME` and `TWINE_PASSWORD`. To configure the latter as a secret, run the following command:
+
+```
+echo "TWINE_PASSWORD={password}" | travis encrypt
+```
+
+Or disable it in the CI definition and configure it through the web UI.
+
+Features include:
+- test against Python 2 and 3
+- run on Ubuntu Xenial
+- correct for broken IPv6
+
+Also provided is a minimal template for running under Appveyor (Windows).
+
+## Building Documentation
+
+Documentation is automatically built by [Read the Docs](https://readthedocs.org) when the project is registered with it, by way of the .readthedocs.yml file. To test the docs build manually, a tox env may be invoked as `tox -e build-docs`. Both techniques rely on the dependencies declared in `setup.cfg/options.extras_require.docs`.
+
+In addition to building the sphinx docs scaffolded in `docs/`, the docs build a `history.html` file that first injects release dates and hyperlinks into the CHANGES.rst before incorporating it as history in the docs.
+
+## Cutting releases
+
+By default, tagged commits are released through the continuous integration deploy stage.
diff --git a/tests/test_ptr.py b/tests/test_ptr.py
index ce5b2e5..07633b0 100644
--- a/tests/test_ptr.py
+++ b/tests/test_ptr.py
@@ -40,21 +40,16 @@ def venv(virtualenv):
virtualenv.teardown()
-setuptools_reqs = [
- 'setuptools',
- 'setuptools==27.3.0',
- 'setuptools==32.3.1',
- 'setuptools==36.3.0',
-] if sys.version_info < (3, 7) else [
- 'setuptools',
- 'setuptools==38.4.1',
-]
+setuptools_reqs = (
+ ['setuptools', 'setuptools==27.3.0', 'setuptools==32.3.1', 'setuptools==36.3.0']
+ if sys.version_info < (3, 7)
+ else ['setuptools', 'setuptools==38.4.1']
+)
args_variants = ['', '--extras']
@pytest.mark.parametrize(
- 'setuptools_req, test_args',
- itertools.product(setuptools_reqs, args_variants),
+ 'setuptools_req, test_args', itertools.product(setuptools_reqs, args_variants)
)
def test_egg_fetcher(venv, setuptools_req, test_args):
test_args = test_args.split()
@@ -72,9 +67,13 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
dist_version = '0.1'
dist_sdist = '%s-%s.tar.gz' % (dist_name, dist_version)
dist_dir = (index_dir / dist_name).mkdir()
- make_sdist(dist_dir / dist_sdist, (
- ('setup.py', textwrap.dedent(
- '''
+ make_sdist(
+ dist_dir / dist_sdist,
+ (
+ (
+ 'setup.py',
+ textwrap.dedent(
+ '''
from setuptools import setup
setup(
name={dist_name!r},
@@ -82,29 +81,35 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
py_modules=[{dist_name!r}],
)
'''
- ).format(dist_name=dist_name, dist_version=dist_version)),
- (dist_name + '.py', ''),
- ))
+ ).format(dist_name=dist_name, dist_version=dist_version),
+ ),
+ (dist_name + '.py', ''),
+ ),
+ )
with (dist_dir / 'index.html').open('w') as fp:
- fp.write(DALS(
- '''
+ fp.write(
+ DALS(
+ '''
<!DOCTYPE html><html><body>
<a href="{dist_sdist}" rel="internal">{dist_sdist}</a><br/>
</body></html>
'''
- ).format(dist_sdist=dist_sdist))
+ ).format(dist_sdist=dist_sdist)
+ )
# Move barbazquux1 out of the index.
shutil.move(index_dir / 'barbazquux1', venv.workspace)
barbazquux1_link = (
- 'file://' + str(venv.workspace.abspath())
+ 'file://'
+ + str(venv.workspace.abspath())
+ '/barbazquux1/barbazquux1-0.1.tar.gz'
+ '#egg=barbazquux1-0.1'
)
# Prepare fake project.
project_dir = (venv.workspace / 'project-0.1').mkdir()
with open(project_dir / 'setup.py', 'w') as fp:
- fp.write(DALS(
- '''
+ fp.write(
+ DALS(
+ '''
from setuptools import setup
setup(
name='project',
@@ -128,17 +133,22 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
'extra': 'barbazquux5',
}}
)
- ''').format(sys_platform=sys.platform,
- barbazquux1_link=barbazquux1_link))
- with open(project_dir / 'setup.cfg', 'w') as fp:
- fp.write(DALS(
'''
+ ).format(sys_platform=sys.platform, barbazquux1_link=barbazquux1_link)
+ )
+ with open(project_dir / 'setup.cfg', 'w') as fp:
+ fp.write(
+ DALS(
+ '''
[easy_install]
index_url = .
- '''))
- with open(project_dir / 'test_stuff.py', 'w') as fp:
- fp.write(DALS(
'''
+ )
+ )
+ with open(project_dir / 'test_stuff.py', 'w') as fp:
+ fp.write(
+ DALS(
+ '''
import pytest
def test_stuff():
@@ -152,7 +162,9 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
else:
with pytest.raises(ImportError):
import barbazquux5
- ''').format(importable_barbazquux5=('--extras' in test_args)))
+ '''
+ ).format(importable_barbazquux5=('--extras' in test_args))
+ )
# Run fake project tests.
cmd = 'python setup.py pytest'.split()
cmd += ['--index-url=' + index_dir.abspath()]
diff --git a/tox.ini b/tox.ini
index 1d5e281..82fb9ea 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,19 +1,18 @@
[tox]
envlist = python
-minversion = 2.4
+minversion = 3.2
+# https://github.com/jaraco/skeleton/issues/6
+tox_pip_extensions_ext_venv_update = true
[testenv]
deps =
setuptools>=31.0.1
- # workaround for yaml/pyyaml#126
- # git+https://github.com/yaml/pyyaml@master#egg=pyyaml;python_version=="3.7"
# workaround for https://github.com/manahl/pytest-plugins/issues/110
pytest < 4
# workaround for https://github.com/manahl/pytest-plugins/issues/122
virtualenv
commands =
- py.test {posargs}
- python setup.py checkdocs
+ pytest {posargs}
usedevelop = True
extras = testing
@@ -24,3 +23,15 @@ extras =
changedir = docs
commands =
python -m sphinx . {toxinidir}/build/html
+
+[testenv:release]
+skip_install = True
+deps =
+ pep517>=0.5
+ # workaround for https://github.com/pypa/twine/issues/423
+ git+https://github.com/pypa/twine
+ path.py
+commands =
+ python -c "import path; path.Path('dist').rmtree_p()"
+ python -m pep517.build .
+ python -m twine upload dist/*