summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
Diffstat (limited to 'README')
-rw-r--r--README17
1 files changed, 16 insertions, 1 deletions
diff --git a/README b/README
index 6247cff..c249394 100644
--- a/README
+++ b/README
@@ -26,9 +26,24 @@ Usage
Example
-------
+The most simple usage looks like this in setup.py::
+
+ setup(
+ setup_requires=[
+ 'pytest-runner',
+ ],
+ tests_require=[
+ 'pytest',
+ ],
+ )
+
+Additional dependencies require to run the tests (e.g. mock or pytest
+plugins) may be added to tests_require and will be downloaded and
+required by the session before invoking pytest.
+
See the `jaraco.collections
<https://bitbucket.org/jaraco/jaraco.collections/>`_ project
-for example usage.
+for real-world usage.
Considerations
--------------