summaryrefslogtreecommitdiff
path: root/command.py
diff options
context:
space:
mode:
Diffstat (limited to 'command.py')
-rw-r--r--command.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/command.py b/command.py
index b4fe24f..8ce9a42 100644
--- a/command.py
+++ b/command.py
@@ -4,8 +4,7 @@ Setup scripts can use this to add setup.py test support for pytest runner.
Recommended usage:
execfile('pytest-runner/command.py')
-setup_params = dict(...)
-PyTest.install(setup_params)
+setup_params = PyTest.install(dict(...))
setuptools.setup(**setup_params)
"""
@@ -112,3 +111,4 @@ class PyTest(_pytest_runner_test.test):
setup_params.setdefault('cmdclass', {}).update(
test=cls,
)
+ return setup_params