summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 16 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 72d901c..1e95a0e 100644
--- a/setup.py
+++ b/setup.py
@@ -9,8 +9,8 @@ import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-name = 'skeleton'
-description = ''
+name = 'pytest-runner'
+description = 'Invoke py.test as distutils command with dependency resolution'
nspkg_technique = 'native'
"""
Does this package use "native" namespace packages or
@@ -24,20 +24,24 @@ params = dict(
author_email="jaraco@jaraco.com",
description=description or name,
long_description=long_description,
- url="https://github.com/jaraco/" + name,
- packages=setuptools.find_packages(),
- include_package_data=True,
+ url="https://github.com/pytest-dev/" + name,
namespace_packages=(
name.split('.')[:-1] if nspkg_technique == 'managed'
else []
),
- python_requires='>=2.7',
+ py_modules=['ptr'],
+ python_requires='>=2.6',
install_requires=[
],
extras_require={
'testing': [
'pytest>=2.8',
'pytest-sugar',
+ 'pytest-virtualenv',
+ ],
+ 'testing:python_version=="2.6"': [
+ # undeclared dependency of pytest-virtualenv
+ 'importlib',
],
'docs': [
'sphinx',
@@ -52,10 +56,16 @@ params = dict(
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
+ "Framework :: Pytest",
],
entry_points={
+ 'distutils.commands': [
+ 'ptr = ptr:PyTest',
+ 'pytest = ptr:PyTest',
+ ],
},
)
if __name__ == '__main__':