summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 11 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 157ecb2..f587434 100644
--- a/setup.py
+++ b/setup.py
@@ -9,8 +9,8 @@ import setuptools
with io.open('README.rst', encoding='utf-8') as readme:
long_description = readme.read()
-name = 'skeleton'
-description = ''
+name = 'pytest-runner'
+description = 'Invoke py.test as distutils command with dependency resolution'
params = dict(
name=name,
@@ -19,10 +19,9 @@ params = dict(
author_email="jaraco@jaraco.com",
description=description or name,
long_description=long_description,
- url="https://github.com/jaraco/" + name,
- packages=setuptools.find_packages(),
- include_package_data=True,
+ url="https://github.com/pytest-dev/" + name,
namespace_packages=name.split('.')[:-1],
+ py_modules=['ptr'],
install_requires=[
],
extras_require={
@@ -34,10 +33,16 @@ params = dict(
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
+ "Framework :: Pytest",
],
- entry_points={
+ entry_points = {
+ 'distutils.commands': [
+ 'ptr = ptr:PyTest',
+ 'pytest = ptr:PyTest',
+ ],
},
)
if __name__ == '__main__':