summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py87
1 files changed, 53 insertions, 34 deletions
diff --git a/setup.py b/setup.py
index d94fb81..81e7211 100644
--- a/setup.py
+++ b/setup.py
@@ -1,34 +1,53 @@
-#!/usr/bin/env python
-# Generated by jaraco.develop (https://bitbucket.org/jaraco/jaraco.develop)
-import setuptools
-
-setup_params = dict(
- name='pytest-runner',
- get_version_from_scm=True,
- author="Jason R. Coombs",
- author_email="jaraco@jaraco.com",
- url="https://bitbucket.org/jaraco/pytest-runner",
- description="Invoke py.test as distutils command with dependency "
- "resolution.",
- py_modules = ['ptr'],
- zip_safe=True,
- entry_points = {
- 'distutils.commands': [
- 'ptr = ptr:PyTest',
- 'pytest = ptr:PyTest',
- ],
- },
- license = 'MIT',
- classifiers = [
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- ],
- setup_requires=[
- 'hgdistver',
- ],
-)
-if __name__ == '__main__':
- setuptools.setup(**setup_params)
+#!/usr/bin/env python
+# Generated by jaraco.develop 2.14
+# https://pypi.python.org/pypi/jaraco.develop
+
+import io
+import sys
+
+import setuptools
+
+with io.open('README.txt', encoding='utf-8') as readme:
+ long_description = readme.read()
+
+needs_pytest = {'pytest', 'test'}.intersection(sys.argv)
+pytest_runner = ['pytest_runner'] if needs_pytest else []
+needs_sphinx = {'release', 'build_sphinx', 'upload_docs'}.intersection(sys.argv)
+sphinx = ['sphinx'] if needs_sphinx else []
+
+setup_params = dict(
+ name='pytest-runner',
+ use_scm_version=True,
+ author="Jason R. Coombs",
+ author_email="jaraco@jaraco.com",
+ description="Invoke py.test as distutils command with dependency "
+ "resolution.",
+ long_description=long_description,
+ url="https://bitbucket.org/jaraco/pytest-runner",
+ py_modules=['ptr'],
+ entry_points = {
+ 'distutils.commands': [
+ 'ptr = ptr:PyTest',
+ 'pytest = ptr:PyTest',
+ ],
+ },
+ install_requires=[
+ ],
+ setup_requires=[
+ 'setuptools_scm',
+ ] + pytest_runner + sphinx,
+ tests_require=[
+ 'pytest',
+ ],
+ license='MIT',
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ ],
+)
+if __name__ == '__main__':
+ setuptools.setup(**setup_params)