summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 10 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ac40a89..81e7211 100644
--- a/setup.py
+++ b/setup.py
@@ -20,11 +20,17 @@ setup_params = dict(
use_scm_version=True,
author="Jason R. Coombs",
author_email="jaraco@jaraco.com",
- description="pytest-runner",
+ description="Invoke py.test as distutils command with dependency "
+ "resolution.",
long_description=long_description,
url="https://bitbucket.org/jaraco/pytest-runner",
- packages=setuptools.find_packages(),
- namespace_packages=[''],
+ py_modules=['ptr'],
+ entry_points = {
+ 'distutils.commands': [
+ 'ptr = ptr:PyTest',
+ 'pytest = ptr:PyTest',
+ ],
+ },
install_requires=[
],
setup_requires=[
@@ -38,6 +44,7 @@ setup_params = dict(
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
],