summaryrefslogtreecommitdiff
path: root/tests/test_ptr.py
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test_ptr.py')
-rw-r--r--tests/test_ptr.py74
1 files changed, 43 insertions, 31 deletions
diff --git a/tests/test_ptr.py b/tests/test_ptr.py
index ce5b2e5..07633b0 100644
--- a/tests/test_ptr.py
+++ b/tests/test_ptr.py
@@ -40,21 +40,16 @@ def venv(virtualenv):
virtualenv.teardown()
-setuptools_reqs = [
- 'setuptools',
- 'setuptools==27.3.0',
- 'setuptools==32.3.1',
- 'setuptools==36.3.0',
-] if sys.version_info < (3, 7) else [
- 'setuptools',
- 'setuptools==38.4.1',
-]
+setuptools_reqs = (
+ ['setuptools', 'setuptools==27.3.0', 'setuptools==32.3.1', 'setuptools==36.3.0']
+ if sys.version_info < (3, 7)
+ else ['setuptools', 'setuptools==38.4.1']
+)
args_variants = ['', '--extras']
@pytest.mark.parametrize(
- 'setuptools_req, test_args',
- itertools.product(setuptools_reqs, args_variants),
+ 'setuptools_req, test_args', itertools.product(setuptools_reqs, args_variants)
)
def test_egg_fetcher(venv, setuptools_req, test_args):
test_args = test_args.split()
@@ -72,9 +67,13 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
dist_version = '0.1'
dist_sdist = '%s-%s.tar.gz' % (dist_name, dist_version)
dist_dir = (index_dir / dist_name).mkdir()
- make_sdist(dist_dir / dist_sdist, (
- ('setup.py', textwrap.dedent(
- '''
+ make_sdist(
+ dist_dir / dist_sdist,
+ (
+ (
+ 'setup.py',
+ textwrap.dedent(
+ '''
from setuptools import setup
setup(
name={dist_name!r},
@@ -82,29 +81,35 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
py_modules=[{dist_name!r}],
)
'''
- ).format(dist_name=dist_name, dist_version=dist_version)),
- (dist_name + '.py', ''),
- ))
+ ).format(dist_name=dist_name, dist_version=dist_version),
+ ),
+ (dist_name + '.py', ''),
+ ),
+ )
with (dist_dir / 'index.html').open('w') as fp:
- fp.write(DALS(
- '''
+ fp.write(
+ DALS(
+ '''
<!DOCTYPE html><html><body>
<a href="{dist_sdist}" rel="internal">{dist_sdist}</a><br/>
</body></html>
'''
- ).format(dist_sdist=dist_sdist))
+ ).format(dist_sdist=dist_sdist)
+ )
# Move barbazquux1 out of the index.
shutil.move(index_dir / 'barbazquux1', venv.workspace)
barbazquux1_link = (
- 'file://' + str(venv.workspace.abspath())
+ 'file://'
+ + str(venv.workspace.abspath())
+ '/barbazquux1/barbazquux1-0.1.tar.gz'
+ '#egg=barbazquux1-0.1'
)
# Prepare fake project.
project_dir = (venv.workspace / 'project-0.1').mkdir()
with open(project_dir / 'setup.py', 'w') as fp:
- fp.write(DALS(
- '''
+ fp.write(
+ DALS(
+ '''
from setuptools import setup
setup(
name='project',
@@ -128,17 +133,22 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
'extra': 'barbazquux5',
}}
)
- ''').format(sys_platform=sys.platform,
- barbazquux1_link=barbazquux1_link))
- with open(project_dir / 'setup.cfg', 'w') as fp:
- fp.write(DALS(
'''
+ ).format(sys_platform=sys.platform, barbazquux1_link=barbazquux1_link)
+ )
+ with open(project_dir / 'setup.cfg', 'w') as fp:
+ fp.write(
+ DALS(
+ '''
[easy_install]
index_url = .
- '''))
- with open(project_dir / 'test_stuff.py', 'w') as fp:
- fp.write(DALS(
'''
+ )
+ )
+ with open(project_dir / 'test_stuff.py', 'w') as fp:
+ fp.write(
+ DALS(
+ '''
import pytest
def test_stuff():
@@ -152,7 +162,9 @@ def test_egg_fetcher(venv, setuptools_req, test_args):
else:
with pytest.raises(ImportError):
import barbazquux5
- ''').format(importable_barbazquux5=('--extras' in test_args)))
+ '''
+ ).format(importable_barbazquux5=('--extras' in test_args))
+ )
# Run fake project tests.
cmd = 'python setup.py pytest'.split()
cmd += ['--index-url=' + index_dir.abspath()]