summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 11 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 16bf78a..df1b0ef 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,9 +1,20 @@
[tox]
+envlist = python
minversion = 2.4
[testenv]
+deps =
+ setuptools>=31.0.1
commands =
py.test {posargs}
python setup.py checkdocs
usedevelop = True
extras = testing
+
+[testenv:build-docs]
+extras =
+ docs
+ testing
+changedir = docs
+commands =
+ python -m sphinx . {toxinidir}/build/html