summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini18
1 files changed, 15 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index 78cc7f9..8a3bf67 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,14 +1,14 @@
[tox]
envlist = python
-minversion = 2.4
+minversion = 3.2
+# https://github.com/jaraco/skeleton/issues/6
+tox_pip_extensions_ext_venv_update = true
[testenv]
deps =
setuptools>=31.0.1
- pytest-sugar-bugfix159
commands =
pytest {posargs}
- python setup.py checkdocs
usedevelop = True
extras = testing
@@ -19,3 +19,15 @@ extras =
changedir = docs
commands =
python -m sphinx . {toxinidir}/build/html
+
+[testenv:release]
+skip_install = True
+deps =
+ pep517>=0.5
+ # workaround for https://github.com/pypa/twine/issues/423
+ git+https://github.com/pypa/twine
+ path.py
+commands =
+ python -c "import path; path.Path('dist').rmtree_p()"
+ python -m pep517.build .
+ python -m twine upload dist/*