summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini17
1 files changed, 13 insertions, 4 deletions
diff --git a/tox.ini b/tox.ini
index c2bac45..70b0be7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,11 +5,8 @@ minversion = 2.4
[testenv]
deps =
setuptools>=31.0.1
- # workaround for yaml/pyyaml#126
- # git+https://github.com/yaml/pyyaml@master#egg=pyyaml;python_version=="3.7"
commands =
- py.test {posargs}
- python setup.py checkdocs
+ pytest {posargs}
usedevelop = True
extras = testing
@@ -20,3 +17,15 @@ extras =
changedir = docs
commands =
python -m sphinx . {toxinidir}/build/html
+
+[testenv:release]
+skip_install = True
+deps =
+ pep517>=0.5
+ # workaround for https://github.com/pypa/twine/issues/423
+ git+https://github.com/pypa/twine
+ path.py
+commands =
+ python -c "import path; path.Path('dist').rmtree_p()"
+ python -m pep517.build .
+ python -m twine upload dist/*