summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsobolevn <mail@sobolevn.me>2018-12-26 00:31:27 +0300
committersobolevn <mail@sobolevn.me>2018-12-26 00:31:27 +0300
commit9636894e0c2d1379ced9c586e57012db8b287148 (patch)
tree1356bcefb95bf4babf1b42055604850aba9f178f
parent861fd4d116d2f8b2b24fd2a4293d5bce67c238d3 (diff)
downloadpython-decorator-git-9636894e0c2d1379ced9c586e57012db8b287148.tar.gz
Adds python3.7 support
-rw-r--r--.travis.yml20
-rw-r--r--README.rst8
2 files changed, 16 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 1047353..377c5fb 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,14 +2,18 @@ sudo: false
language: python
-python:
- - "2.6"
- - "2.7"
- - "3.2"
- - "3.3"
- - "3.4"
- - "3.5"
- - "3.6"
+matrix:
+ include:
+ - python: 2.6
+ - python: 2.7
+ - python: 3.2
+ - python: 3.3
+ - python: 3.4
+ - python: 3.5
+ - python: 3.6
+ - python: 3.7
+ dist: xenial
+ sudo: true
install:
- python setup.py install
diff --git a/README.rst b/README.rst
index ad72633..d2ca3f2 100644
--- a/README.rst
+++ b/README.rst
@@ -3,7 +3,7 @@ Decorator module
:Author: Michele Simionato
:E-mail: michele.simionato@gmail.com
-:Requires: Python from 2.6 to 3.6
+:Requires: Python from 2.6 to 3.7
:Download page: http://pypi.python.org/pypi/decorator
:Installation: ``pip install decorator``
:License: BSD license
@@ -65,7 +65,7 @@ operations:
.. code-block:: python
from decorator import decorator
-
+
@decorator
def warn_slow(func, timelimit=60, *args, **kw):
t0 = time.time()
@@ -76,11 +76,11 @@ operations:
else:
logging.info('%s took %d seconds', func.__name__, dt)
return result
-
+
@warn_slow # warn if it takes more than 1 minute
def preprocess_input_files(inputdir, tempdir):
...
-
+
@warn_slow(timelimit=600) # warn if it takes more than 10 minutes
def run_calculation(tempdir, outdir):
...