summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Hupp <adam@hupp.org>2021-01-15 16:34:09 -0800
committerAdam Hupp <adam@hupp.org>2021-01-15 16:34:09 -0800
commitfca071d6a4ee04fca4cafacd7041a76a32cc1a8d (patch)
tree77e265e048267c176a7e83a06ab6093692dfc8cb
parent3ebdb93cbe5ded066c23b0555f509610287b4ffb (diff)
downloadpython-magic-fca071d6a4ee04fca4cafacd7041a76a32cc1a8d.tar.gz
bump to 0.4.20
-rw-r--r--CHANGELOG2
-rw-r--r--setup.py8
-rw-r--r--upload.sh5
3 files changed, 9 insertions, 6 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 997b28d..751dbb9 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,4 @@
-Changes in 0.4.19
+Changes to 0.4.20
- merge in a compatability layer for the upstream libmagic python binding.
Since both this package and that one are called 'magic', this compat layer
diff --git a/setup.py b/setup.py
index 5d279f2..e5df93a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-from setuptools import setup
+import setuptools
import io
import os
@@ -12,16 +12,16 @@ def read(file_name):
encoding='utf-8') as f:
return f.read()
-setup(
+setuptools.setup(
name='python-magic',
description='File type identification using libmagic',
author='Adam Hupp',
author_email='adam@hupp.org',
url="http://github.com/ahupp/python-magic",
- version='0.4.19',
- py_modules=['magic'],
+ version='0.4.20',
long_description=read('README.md'),
long_description_content_type='text/markdown',
+ packages=setuptools.find_packages(),
keywords="mime magic file",
license="MIT",
python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
diff --git a/upload.sh b/upload.sh
index ca9c36f..5fc8e25 100644
--- a/upload.sh
+++ b/upload.sh
@@ -1,3 +1,6 @@
#!/bin/sh
-python setup.py sdist bdist_wheel upload
+python3 setup.py clean --all
+python3 setup.py sdist bdist_wheel
+#python3 -m twine upload dist/*
+