summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Vinot <raphael@vinot.info>2015-11-06 19:18:45 +0100
committerRaphaël Vinot <raphael@vinot.info>2015-11-06 19:18:45 +0100
commit505d499185062aa42d1da19e3d7c1dc6b16b3afd (patch)
treec664ecf624c2fb0bb40db1fa3967349df3376fe1
parent3069a4a01a9551d654460214b40123bec2bc6592 (diff)
downloadpython-magic-505d499185062aa42d1da19e3d7c1dc6b16b3afd.tar.gz
Fix travis config
The tests fail on travis ci because the libmagic 5.09 is buggy.
-rw-r--r--.travis.yml16
-rw-r--r--setup.py6
-rw-r--r--test/__init__.py0
-rwxr-xr-x[-rw-r--r--]test/test.py0
4 files changed, 19 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index e2246f6..619d195 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,8 +1,22 @@
language: python
+
python:
- "2.6"
- "2.7"
- "3.2"
- "3.3"
+ - "3.4"
+ - "3.5"
+ - "nightly"
+
+install:
+ - pip install coveralls
+ - pip install codecov
+ - python setup.py install
+
script:
- - python test.py
+ - coverage run setup.py test
+
+after_success:
+ - coveralls
+ - codecov
diff --git a/setup.py b/setup.py
index eac534b..4e816f7 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,7 @@
-from setuptools import setup, Extension
-#from distutils.core import setup, Extension
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+from setuptools import setup
setup(name='python-magic',
description='File type identification using libmagic',
diff --git a/test/__init__.py b/test/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test/__init__.py
diff --git a/test/test.py b/test/test.py
index b74a25f..b74a25f 100644..100755
--- a/test/test.py
+++ b/test/test.py