summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG32
1 files changed, 32 insertions, 0 deletions
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 0000000..a9d62af
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,32 @@
+Changes in 0.4.18
+
+- Make bindings for magic_[set|get]param optional, and throw NotImplementedError
+if they are used but not supported. Only call setparam() in the constructor if
+it's supported. This prevents breakage on CentOS7 which uses an old version of
+libmagic.
+
+- Add tests for CentOS 7 & 8
+
+Changes in 0.4.16 and 0.4.17
+
+- add MAGIC_MIME_TYPE constant, use that in preference to MAGIC_MIME internally.
+This sets up for a breaking change in a future major version bump where
+MAGIC_MIME will change to mathch magic.h.
+- add magic.version() function to return library version
+- add setparam/getparam to control internal behavior
+- increase internal limits with setparam to prevent spurious error on some jpeg files
+- various setup.py improvements to declare modern python support
+- support MSYS2 magic dlls
+- fix warning about using 'is' on an int in python 3.8
+- include tests in source distribution
+
+- many test improvements:
+-- tox runner support
+-- remove deprecated test_suite field from setup.py
+-- docker tests that cover all LTS ubuntu versions
+-- add test for snapp file identification
+
+- doc improvements
+-- document dependency install process for debian
+-- various typos
+-- document test running process