summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJT <dieselmachine@gmail.com>2015-10-01 00:13:46 +0000
committerJT <dieselmachine@gmail.com>2015-10-01 00:13:46 +0000
commitb84e904a8cbf31d3f26e000006db24a77051db03 (patch)
tree8e92544226871c0e302ffa8c923619f9a6b1587b
parent37f55ca4ad94ca4ade30d6be28e1facb79ac3182 (diff)
downloadpython-memcached-b84e904a8cbf31d3f26e000006db24a77051db03.tar.gz
(#72) setup.py will now pull the version number directly from memcache.py (using setuptools.depends.get_module_constant) in order to prevent discrepancies
-rw-r--r--memcache.py2
-rw-r--r--setup.py3
2 files changed, 3 insertions, 2 deletions
diff --git a/memcache.py b/memcache.py
index 5d97714..2f1d323 100644
--- a/memcache.py
+++ b/memcache.py
@@ -90,7 +90,7 @@ valid_key_chars_re = re.compile(b'[\x21-\x7e\x80-\xff]+$')
# Original author: Evan Martin of Danga Interactive
__author__ = "Sean Reifschneider <jafo-memcached@tummy.com>"
-__version__ = "1.57"
+__version__ = "1.58"
__copyright__ = "Copyright (C) 2003 Danga Interactive"
# http://en.wikipedia.org/wiki/Python_Software_Foundation_License
__license__ = "Python Software Foundation License"
diff --git a/setup.py b/setup.py
index 891a283..c1dd198 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,11 @@
#!/usr/bin/env python
+from setuptools.depends import get_module_constant
from setuptools import setup # noqa
setup(name="python-memcached",
- version="1.58",
+ version=get_module_constant('memcache', '__version__'),
description="Pure python memcached client",
long_description=open("README.md").read(),
author="Evan Martin",