summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Reifschneider <jafo@tummy.com>2014-03-25 22:07:49 -0600
committerSean Reifschneider <jafo@tummy.com>2014-03-25 22:07:49 -0600
commit780af8fe3723940726c5fbe82e5d692f2a49621f (patch)
treeef1f61dfae36c878245685da8f8d20ad04b7bcfd
parent54279e19d6c36ae2ecc0838817b0feab3bc35899 (diff)
parent4686bafa699af4abfec98e011a00cc17fd1052bf (diff)
downloadpython-memcached-780af8fe3723940726c5fbe82e5d692f2a49621f.tar.gz
Merge pull request #33 from msabramo/travis
Add support for Travis CI
-rw-r--r--.travis.yml8
-rw-r--r--README.md3
-rw-r--r--tests/test_setmulti.py2
3 files changed, 11 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..3a3a3f2
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,8 @@
+language: python
+python:
+ - 2.6
+ - 2.7
+ - pypy
+install: python setup.py install
+before_script: pip install nose
+script: nosetests
diff --git a/README.md b/README.md
index 2f29ab7..cd4a69e 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,6 @@
+[![Build
+Status](https://travis-ci.org/linsomniac/python-memcached.svg)](https://travis-ci.org/linsomniac/python-memcached)
+
This software is a 100% Python interface to the memcached memory cache
daemon. It is the client side software which allows storing values in one
or more, possibly remote, memcached servers. Search google for memcached
diff --git a/tests/test_setmulti.py b/tests/test_setmulti.py
index 815ccfd..3607f02 100644
--- a/tests/test_setmulti.py
+++ b/tests/test_setmulti.py
@@ -63,5 +63,3 @@ class test_Memcached_Set_Multi(unittest.TestCase):
if DEBUG:
print 'set_multi({0!r}) -> {1!r}'.format(mapping, bad_keys)
-
-unittest.main()