summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Cabrera <alejandro.cabrera@rackspace.com>2014-01-15 16:48:04 -0500
committerAlejandro Cabrera <alejandro.cabrera@rackspace.com>2014-01-15 16:48:04 -0500
commitf54705c34b5095e0af11f75e0738204a45fda139 (patch)
tree5126aab835440e3476f9795ac0baf222532409ff
parente47acaf1837f03e1dbd2caff1b6e627d7ac4325e (diff)
downloadpython-memcached-f54705c34b5095e0af11f75e0738204a45fda139.tar.gz
fix(setup): use new reqs files
-rw-r--r--setup.py24
1 files changed, 13 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index f66b227..1b0ed91 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,9 @@
#!/usr/bin/env python
-from setuptools import setup
-import memcache
+from setuptools import setup # noqa
+
+import memcache # noqa
+
setup(name="python-memcached",
version=memcache.__version__,
@@ -14,13 +16,13 @@ setup(name="python-memcached",
url="http://www.tummy.com/Community/software/python-memcached/",
download_url="ftp://ftp.tummy.com/pub/python-memcached/",
py_modules=["memcache"],
+ requirements=open('requirements.txt').read().split(),
classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: Python Software Foundation License",
- "Operating System :: OS Independent",
- "Programming Language :: Python",
- "Topic :: Internet",
- "Topic :: Software Development :: Libraries :: Python Modules",
- ])
-
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Python Software Foundation License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Topic :: Internet",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ])