summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Reifschneider <jafo@tummy.com>2014-05-10 14:23:30 -0600
committerSean Reifschneider <jafo@tummy.com>2014-05-10 14:23:30 -0600
commit0e077ca363fa7e645ed5b2196c8d2024553b48a3 (patch)
tree64dd621a6ac17c75f9723aadba173c4240af56ec
parentaddcde67b4bb4f62f3891503794deaed2f33bf95 (diff)
parentb2cb5e818773dca92055c966585421d517153559 (diff)
downloadpython-memcached-0e077ca363fa7e645ed5b2196c8d2024553b48a3.tar.gz
Merge branch 'cabrera-tox_support'
-rw-r--r--.gitignore1
-rw-r--r--README.md13
-rw-r--r--tests/Makefile7
-rw-r--r--tox.ini26
4 files changed, 40 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index e18136f..203dc32 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*.pyc
/dist
/python_memcached.egg-info
+.tox
diff --git a/README.md b/README.md
index 0811f8a..115115e 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,8 @@
[![Build
Status](https://travis-ci.org/linsomniac/python-memcached.svg)](https://travis-ci.org/linsomniac/python-memcached)
+## Overview
+
This software is a 100% Python interface to the memcached memory cache
daemon. It is the client side software which allows storing values
in one or more, possibly remote, memcached servers. Search google for
@@ -17,3 +19,14 @@ Please report issues and submit code changes to the github repository at:
For changes prior to 2013-03-26, see the old Launchpad repository at:
Historic issues: https://launchpad.net/python-memcached
+
+## Testing
+
+Test patches locally and easily by running tox:
+
+ pip install tox
+ tox -e py27
+
+Test for style by running tox:
+
+ tox -e pep8
diff --git a/tests/Makefile b/tests/Makefile
deleted file mode 100644
index a844aa4..0000000
--- a/tests/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-TESTS = $(wildcard test_*.py)
-
-test:
- @- $(foreach TEST,$(TESTS), \
- echo === Running test: $(TEST); \
- python $(TEST); \
- )
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..a1dcac2
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,26 @@
+[tox]
+minversion = 1.6
+envlist = py26,py27,py33,pypy,pep8
+skipsdist = True
+
+[testenv]
+usedevelop = True
+# Customize pip command, add -U to force updates.
+install_command = pip install -U {opts} {packages}
+deps = nose
+commands = nosetests {posargs}
+
+[tox:jenkins]
+downloadcache = ~/cache/pip
+
+[testenv:pep8]
+deps = hacking
+commands = flake8
+
+[testenv:cover]
+deps = nose
+ coverage
+commands = nosetests --with-coverage {posargs}
+
+[flake8]
+exclude = .venv*,.git,.tox,dist,doc,*openstack/common*,*lib/python*,*.egg,.update-venv