summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Reifschneider <sean@realgo.com>2017-12-15 09:39:50 -0700
committerSean Reifschneider <sean@realgo.com>2017-12-15 09:39:50 -0700
commitbad41222379102e3f18f6f2f7be3ee608de6fbff (patch)
treecb4f7f9fce2168ed78249709afc0ae31a442b38d
parent7942465eba2009927e5d14b4b6dbd48b75780d80 (diff)
downloadpython-memcached-bad41222379102e3f18f6f2f7be3ee608de6fbff.tar.gz
Fixing download URLs, release script
-rwxr-xr-xdo_release3
-rw-r--r--setup.py7
2 files changed, 6 insertions, 4 deletions
diff --git a/do_release b/do_release
index e8c0d91..cc6639e 100755
--- a/do_release
+++ b/do_release
@@ -29,4 +29,5 @@ git push --tags
cd /tmp
release "$VERSION" python-memcached
cd python-memcached-"$VERSION"
-python setup.py sdist bdist_wheel upload
+python setup.py sdist bdist_wheel
+twine upload -r pypitest dist/*"$VERSION"* && twine upload -r pypi dist/*"$VERSION"*
diff --git a/setup.py b/setup.py
index 24da299..93cbe4d 100644
--- a/setup.py
+++ b/setup.py
@@ -4,17 +4,18 @@ from setuptools.depends import get_module_constant
from setuptools import setup # noqa
+version = get_module_constant('memcache', '__version__')
setup(
name="python-memcached",
- version=get_module_constant('memcache', '__version__'),
+ version=version,
description="Pure python memcached client",
long_description=open("README.md").read(),
author="Evan Martin",
author_email="martine@danga.com",
maintainer="Sean Reifschneider",
maintainer_email="jafo@tummy.com",
- url="http://www.tummy.com/Community/software/python-memcached/",
- download_url="ftp://ftp.tummy.com/pub/python-memcached/",
+ url="https://github.com/linsomniac/python-memcached",
+ download_url="https://github.com/linsomniac/python-memcached/releases/download/{0}/python-memcached-{0}.tar.gz".format(version),
py_modules=["memcache"],
install_requires=open('requirements.txt').read().split(),
classifiers=[