summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSean Reifschneider <jafo@tummy.com>2014-03-25 22:45:16 -0600
committerSean Reifschneider <jafo@tummy.com>2014-03-25 22:45:16 -0600
commit179eeca44bfae70cfc4d7f7d2fd10d808f47416f (patch)
tree8c98b8bfaa3e0575abf7bbb195b2c9f7699f2be7 /setup.py
parente3468928c53588e66bfabcbe6fde639222de02b3 (diff)
parent853040beb9d2b709e67cae77fffd08dceab8b61a (diff)
downloadpython-memcached-179eeca44bfae70cfc4d7f7d2fd10d808f47416f.tar.gz
Merge branch 'py33_fixes' of https://github.com/cabrera/python-memcached into cabrera-py33_fixes
Conflicts: README.md memcache.py tests/test_setmulti.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 12 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index f66b227..96f5787 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,10 @@
#!/usr/bin/env python
-from setuptools import setup
-import memcache
+from setuptools import setup # noqa
+
setup(name="python-memcached",
- version=memcache.__version__,
+ version="1.53",
description="Pure python memcached client",
long_description=open("README.md").read(),
author="Evan Martin",
@@ -14,13 +14,13 @@ setup(name="python-memcached",
url="http://www.tummy.com/Community/software/python-memcached/",
download_url="ftp://ftp.tummy.com/pub/python-memcached/",
py_modules=["memcache"],
+ requirements=open('requirements.txt').read().split(),
classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: Python Software Foundation License",
- "Operating System :: OS Independent",
- "Programming Language :: Python",
- "Topic :: Internet",
- "Topic :: Software Development :: Libraries :: Python Modules",
- ])
-
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Python Software Foundation License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Topic :: Internet",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ])