summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--memcache.py2
-rw-r--r--setup.py3
2 files changed, 3 insertions, 2 deletions
diff --git a/memcache.py b/memcache.py
index 86aed82..f0dccd8 100644
--- a/memcache.py
+++ b/memcache.py
@@ -95,7 +95,7 @@ valid_key_chars_re = re.compile(b'[\x21-\x7e\x80-\xff]+$')
# Original author: Evan Martin of Danga Interactive
__author__ = "Sean Reifschneider <jafo-memcached@tummy.com>"
-__version__ = "1.57"
+__version__ = "1.58"
__copyright__ = "Copyright (C) 2003 Danga Interactive"
# http://en.wikipedia.org/wiki/Python_Software_Foundation_License
__license__ = "Python Software Foundation License"
diff --git a/setup.py b/setup.py
index 891a283..c1dd198 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,11 @@
#!/usr/bin/env python
+from setuptools.depends import get_module_constant
from setuptools import setup # noqa
setup(name="python-memcached",
- version="1.58",
+ version=get_module_constant('memcache', '__version__'),
description="Pure python memcached client",
long_description=open("README.md").read(),
author="Evan Martin",