summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Wojcik <wojcikstefan@gmail.com>2016-01-27 10:39:06 -0800
committerStefan Wojcik <wojcikstefan@gmail.com>2016-01-27 10:39:06 -0800
commit825e4e5b6c70d35e826ddfa5650de428a1892030 (patch)
tree07e9ebc80b2d7aca9e20cab6fd0ec6ad958f7e0c
parenta37c9d3fe7861dfa98791da59d670dc8289596c1 (diff)
downloadpython-mimeparse-825e4e5b6c70d35e826ddfa5650de428a1892030.tar.gz
remove an unnecessary import + add info about pep8 & pyflakes to the readme
-rw-r--r--README10
-rwxr-xr-xmimeparse_test.py1
2 files changed, 9 insertions, 2 deletions
diff --git a/README b/README
index d5c925d..ea9d942 100644
--- a/README
+++ b/README
@@ -21,4 +21,12 @@ Python
The Python tests require Python 2.6.
Run the tests by typing:
-python mimeparse_test.py \ No newline at end of file
+python mimeparse_test.py
+
+Make sure the package conforms to the PEP8 style guide:
+pep8 --statistics --show-source --ignore=E501 --exclude=venv .
+
+Check the code for simple warnings and errors:
+pyflakes mimeparse.py mimeparse_test.py setup.py
+
+You may need to install pep8 and pyflakes via pip to run these 2 tests.
diff --git a/mimeparse_test.py b/mimeparse_test.py
index e9ef311..6d00238 100755
--- a/mimeparse_test.py
+++ b/mimeparse_test.py
@@ -8,7 +8,6 @@ of PyUnitTestCases. Then it uses PyUnit to run them and report their status.
import json
import mimeparse
import unittest
-from functools import partial
__version__ = "0.1"