summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDB Tsai <dbtsai@Mac-Pro.local>2016-01-31 18:01:55 -0800
committerDB Tsai <dbtsai@Mac-Pro.local>2016-01-31 18:01:55 -0800
commit0dd88a9e3b5fde9845cf3edd5ea640c4ba90ee10 (patch)
treea43a455d4ede96a726ae041c1f85bc6a3833004a
parent899d0dd547d9944fe257d3c8a2e5e9d53ef13e3c (diff)
downloadpython-mimeparse-0dd88a9e3b5fde9845cf3edd5ea640c4ba90ee10.tar.gz
Release 1.5
-rw-r--r--PKG-INFO50
-rwxr-xr-xsetup.py2
2 files changed, 1 insertions, 51 deletions
diff --git a/PKG-INFO b/PKG-INFO
deleted file mode 100644
index 5631b00..0000000
--- a/PKG-INFO
+++ /dev/null
@@ -1,50 +0,0 @@
-Metadata-Version: 1.1
-Name: python-mimeparse
-Version: 0.1.4.1
-Summary: A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.
-Home-page: https://github.com/dbtsai/python-mimeparse
-Author: DB Tsai
-Author-email: dbtsai@dbtsai.com
-License: UNKNOWN
-Download-URL: http://pypi.python.org/packages/source/p/python-mimeparse/python-mimeparse-0.1.4.1.tar.gz
-Description: # Travis CI Build Status [![Build Status](https://travis-ci.org/dbtsai/python-mimeparse.svg?branch=master)](https://travis-ci.org/dbtsai/python-mimeparse)
-
- This module provides basic functions for handling mime-types. It can handle
- matching mime-types against a list of media-ranges. See section 14.1 of
- the HTTP specification [RFC 2616] for a complete explanation.
-
- http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.1
-
- Contents:
- - parse_mime_type(): Parses a mime-type into its component parts.
- - parse_media_range(): Media-ranges are mime-types with wild-cards and a "q" quality parameter.
- - quality(): Determines the quality ("q") of a mime-type when compared against a list of media-ranges.
- - quality_parsed(): Just like quality() except the second parameter must be pre-parsed.
- - best_match(): Choose the mime-type with the highest quality ("q") from a list of candidates.
-
- Testing
- =======
- The format of the JSON test data file is as follows:
- A top-level JSON object which has a key for each of the functions to be tested. The value corresponding to that key is a list of tests. Each test contains: the argument or arguments to the function being tested, the expected results and an optional description.
-
- Python
- ======
- The Python tests require Python 2.6.
-
- Run the tests by typing:
- python mimeparse_test.py
-
- To make sure that the package works in all the supported environments, you can run tox tests:
- pip install tox
- tox
-
-Keywords: mime-type
-Platform: UNKNOWN
-Classifier: Programming Language :: Python
-Classifier: Programming Language :: Python :: 3
-Classifier: License :: OSI Approved :: MIT License
-Classifier: Operating System :: OS Independent
-Classifier: Development Status :: 5 - Production/Stable
-Classifier: Intended Audience :: Developers
-Classifier: Topic :: Internet :: WWW/HTTP
-Classifier: Topic :: Software Development :: Libraries :: Python Modules
diff --git a/setup.py b/setup.py
index 2e8b9a0..338bc00 100755
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ def read(fname):
setup(
name="python-mimeparse",
py_modules=["mimeparse"],
- version=mimeparse.__version__,
+ version=1.5,
description=("A module provides basic functions for parsing mime-type "
"names and matching them against a list of media-ranges."),
author="DB Tsai",