summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Wojcik <wojcikstefan@gmail.com>2016-01-27 11:40:38 -0800
committerStefan Wojcik <wojcikstefan@gmail.com>2016-01-27 11:40:38 -0800
commit1df55be08efe6d6c2064e670671e50055aeb1276 (patch)
tree1f50c577342cdcafd0b45a2870bc8453f9404b0a
parent627593590bcd369f4d448f5d3cd8bf32a4568e25 (diff)
downloadpython-mimeparse-1df55be08efe6d6c2064e670671e50055aeb1276.tar.gz
tox in the readme + remove py32 from travis
-rw-r--r--.travis.yml1
-rw-r--r--README10
2 files changed, 3 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index cb5b1e1..dde1451 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,7 +5,6 @@ python:
env:
- TOXENV=py27
- - TOXENV=py32
- TOXENV=py34
- TOXENV=pypy
- TOXENV=pep8,pyflakes
diff --git a/README b/README
index ea9d942..0b43d2c 100644
--- a/README
+++ b/README
@@ -23,10 +23,6 @@ The Python tests require Python 2.6.
Run the tests by typing:
python mimeparse_test.py
-Make sure the package conforms to the PEP8 style guide:
-pep8 --statistics --show-source --ignore=E501 --exclude=venv .
-
-Check the code for simple warnings and errors:
-pyflakes mimeparse.py mimeparse_test.py setup.py
-
-You may need to install pep8 and pyflakes via pip to run these 2 tests.
+To make sure that the package works in all the supported environments, you can run tox tests:
+pip install tox
+tox