summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDB Tsai <dbtsai@Mac-Pro.local>2016-01-31 17:41:40 -0800
committerDB Tsai <dbtsai@Mac-Pro.local>2016-01-31 17:41:40 -0800
commit8e5a9880fb9286160d0191317c6104e8f0d5da36 (patch)
tree3f85467728f21f3a9d3c896ab72c1c1221204581
parent1395615bd60e66362c37fa8f57ea9a83018e49b9 (diff)
downloadpython-mimeparse-8e5a9880fb9286160d0191317c6104e8f0d5da36.tar.gz
Uploaded to pypi
-rw-r--r--PKG-INFO25
-rwxr-xr-xsetup.py2
2 files changed, 22 insertions, 5 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 3e4b65e..5631b00 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,13 +1,14 @@
Metadata-Version: 1.1
Name: python-mimeparse
-Version: 0.1.4
+Version: 0.1.4.1
Summary: A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.
Home-page: https://github.com/dbtsai/python-mimeparse
-Author: David Tsai
+Author: DB Tsai
Author-email: dbtsai@dbtsai.com
License: UNKNOWN
-Download-URL: http://pypi.python.org/packages/source/p/python-mimeparse/python-mimeparse-0.1.4.tar.gz
-Description:
+Download-URL: http://pypi.python.org/packages/source/p/python-mimeparse/python-mimeparse-0.1.4.1.tar.gz
+Description: # Travis CI Build Status [![Build Status](https://travis-ci.org/dbtsai/python-mimeparse.svg?branch=master)](https://travis-ci.org/dbtsai/python-mimeparse)
+
This module provides basic functions for handling mime-types. It can handle
matching mime-types against a list of media-ranges. See section 14.1 of
the HTTP specification [RFC 2616] for a complete explanation.
@@ -21,6 +22,22 @@ Description:
- quality_parsed(): Just like quality() except the second parameter must be pre-parsed.
- best_match(): Choose the mime-type with the highest quality ("q") from a list of candidates.
+ Testing
+ =======
+ The format of the JSON test data file is as follows:
+ A top-level JSON object which has a key for each of the functions to be tested. The value corresponding to that key is a list of tests. Each test contains: the argument or arguments to the function being tested, the expected results and an optional description.
+
+ Python
+ ======
+ The Python tests require Python 2.6.
+
+ Run the tests by typing:
+ python mimeparse_test.py
+
+ To make sure that the package works in all the supported environments, you can run tox tests:
+ pip install tox
+ tox
+
Keywords: mime-type
Platform: UNKNOWN
Classifier: Programming Language :: Python
diff --git a/setup.py b/setup.py
index ae39488..2e8b9a0 100755
--- a/setup.py
+++ b/setup.py
@@ -32,5 +32,5 @@ setup(
"Topic :: Internet :: WWW/HTTP",
"Topic :: Software Development :: Libraries :: Python Modules",
],
- long_description=read('README')
+ long_description=read('README.md')
)