summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Caselli <cfederico87@gmail.com>2021-10-26 21:09:34 +0200
committerFederico Caselli <cfederico87@gmail.com>2021-10-26 21:09:34 +0200
commit29ea35d0f4c415a8a390a28fa41c5fc3bc64df0a (patch)
tree3e7cf7766161a9e1f90ed7829df3ddaa52d16784
parentfc26ce79c7538907dbf199689db8e6762944ad24 (diff)
downloadpython-mimeparse-29ea35d0f4c415a8a390a28fa41c5fc3bc64df0a.tar.gz
Use pep517 to build
-rw-r--r--MANIFEST.in2
-rw-r--r--pyproject.toml6
-rw-r--r--setup.cfg3
3 files changed, 7 insertions, 4 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index d071265..3bdb9ab 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1 +1 @@
-include README.rst LICENSE mimeparse_test.py testdata.json
+include README.rst LICENSE mimeparse_test.py testdata.json pyproject.toml
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..c4ef621
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,6 @@
+[build-system]
+ build-backend = "setuptools.build_meta"
+ requires = [
+ "setuptools>=47",
+ "wheel>=0.34",
+ ]
diff --git a/setup.cfg b/setup.cfg
index 60afdbe..dc7d900 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -38,6 +38,3 @@ py_modules = mimeparse
install_requires =
tests_require =
pytest
-
-[bdist_wheel]
-universal = 1