summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Caselli <cfederico87@gmail.com>2021-10-26 20:58:42 +0200
committerFederico Caselli <cfederico87@gmail.com>2021-10-26 20:58:42 +0200
commitfc26ce79c7538907dbf199689db8e6762944ad24 (patch)
treeeee856202d532fd298f7644b80afa6a575e7b25d
parent186b3b9a0a933a05c15194d520e0e7a1a6729442 (diff)
downloadpython-mimeparse-fc26ce79c7538907dbf199689db8e6762944ad24.tar.gz
Move setup information to setup.cfg
-rw-r--r--setup.cfg41
-rwxr-xr-xsetup.py61
2 files changed, 42 insertions, 60 deletions
diff --git a/setup.cfg b/setup.cfg
index 2a9acf1..60afdbe 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,2 +1,43 @@
+[metadata]
+name = python-mimeparse
+version = attr: mimeparse.__version__
+description = A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.
+long_description = file: README.rst
+long_description_content_type = text/x-rst
+url = https://github.com/falconry/python-mimeparse
+author = DB Tsai
+author_email = dbtsai@dbtsai.com
+maintainer = Falcon team
+maintainer_email = mail@kgriffs.com
+license = MIT
+license_file = LICENSE
+classifiers =
+ Programming Language :: Python
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+ License :: OSI Approved :: MIT License
+ Operating System :: OS Independent
+ Development Status :: 5 - Production/Stable
+ Intended Audience :: Developers
+ Topic :: Internet :: WWW/HTTP
+ Topic :: Software Development :: Libraries :: Python Modules
+keywords =
+ mime-type
+project_urls =
+ Issue Tracker=https://github.com/falconry/python-mimeparse
+
+[options]
+python_requires = >=3.6
+py_modules = mimeparse
+install_requires =
+tests_require =
+ pytest
+
[bdist_wheel]
universal = 1
diff --git a/setup.py b/setup.py
index 3f10ad3..6068493 100755
--- a/setup.py
+++ b/setup.py
@@ -1,62 +1,3 @@
-#!/usr/bin/env python
-
-import codecs
-import os
-import re
-
from setuptools import setup
-
-def get_version(filename):
- """
- Return package version as listed in `__version__` in 'filename'.
- """
- with open(filename) as fp:
- contents = fp.read()
- return re.search("__version__ = ['\"]([^'\"]+)['\"]", contents).group(1)
-
-
-version = get_version('mimeparse.py')
-if not version:
- raise RuntimeError('Cannot find version information')
-
-
-def read(fname):
- path = os.path.join(os.path.dirname(__file__), fname)
- with codecs.open(path, encoding='utf-8') as fp:
- return fp.read()
-
-
-setup(
- name="python-mimeparse",
- py_modules=["mimeparse"],
- version=version,
- description=("A module provides basic functions for parsing mime-type "
- "names and matching them against a list of media-ranges."),
- author="DB Tsai",
- license="MIT",
- author_email="dbtsai@dbtsai.com",
- url="https://github.com/dbtsai/python-mimeparse",
- download_url=("https://github.com/dbtsai/python-mimeparse/tarball/" + version),
- keywords=["mime-type"],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
- classifiers=[
- "Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
- "License :: OSI Approved :: MIT License",
- "Operating System :: OS Independent",
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "Topic :: Internet :: WWW/HTTP",
- "Topic :: Software Development :: Libraries :: Python Modules",
- ],
- long_description=read('README.rst')
-)
+setup()