summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-09-05 00:28:33 +0300
committerDB Tsai <dbtsai@dbtsai.com>2018-09-04 14:28:33 -0700
commit5b253c7cbef0249aca9532e5c2c1048302657e0c (patch)
tree711a0bd792b9faaef8c745ea23412e477632fae2
parent30a7cf100f4fe1dcbf03a06a760607fe5fd3c73d (diff)
downloadpython-mimeparse-5b253c7cbef0249aca9532e5c2c1048302657e0c.tar.gz
Add python_requires to help pip (#34)
-rw-r--r--README.rst2
-rwxr-xr-xsetup.py1
2 files changed, 2 insertions, 1 deletions
diff --git a/README.rst b/README.rst
index 0874db2..7a115bd 100644
--- a/README.rst
+++ b/README.rst
@@ -18,7 +18,7 @@ Use **pip**:
$ pip install python-mimeparse
-It supports Python 2.7 - 3.5 and PyPy.
+It supports Python 2.7, 3.4+ and PyPy.
Functions
---------
diff --git a/setup.py b/setup.py
index 50a8aa8..d15529a 100755
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ setup(
download_url=("https://github.com/dbtsai/python-mimeparse/tarball/" +
version),
keywords=["mime-type"],
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
classifiers=[
"Programming Language :: Python",
"Programming Language :: Python :: 3",