summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorVille Skyttä <ville.skytta@iki.fi>2016-10-10 18:21:03 +0300
committerStefan Wójcik <wojcikstefan@gmail.com>2016-10-10 11:21:03 -0400
commit3a28e27ba16a2dedd9617ac2836352dd8b5683ea (patch)
tree3ffad863d2012460e212af5161cebbf3a1760af7 /tox.ini
parent17556a53b5657ac7d2eb4991509e89880b31ec1f (diff)
downloadpython-mimeparse-3a28e27ba16a2dedd9617ac2836352dd8b5683ea.tar.gz
flake8 tweaks (#27)
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini13
1 files changed, 5 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index 62c1338..7977fbe 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py35,py34,py32,py27,pypy,pypy3,pep8,pyflakes
+envlist = py35,py34,py32,py27,pypy,pypy3,flake8
[testenv]
commands = ./mimeparse_test.py
@@ -22,10 +22,7 @@ basepython = pypy
[testenv:pypy3]
basepython = pypy3
-[testenv:pep8]
-deps = pep8
-commands = pep8 --statistics --show-source --ignore=E501 --exclude=.venv,.tox,*egg .
-
-[testenv:pyflakes]
-deps = pyflakes
-commands = pyflakes mimeparse.py mimeparse_test.py setup.py
+[testenv:flake8]
+deps = flake8
+ flake8-import-order
+commands = flake8 --statistics --show-source --ignore=E501 --exclude=.venv,.tox,*egg .