summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2369456..abdd03d 100755
--- a/setup.py
+++ b/setup.py
@@ -1,12 +1,14 @@
#!/usr/bin/env python
import os
+import codecs
import mimeparse
from setuptools import setup
def read(fname):
- return open(os.path.join(os.path.dirname(__file__), fname)).read()
+ path = os.path.join(os.path.dirname(__file__), fname)
+ return codecs.open(path, encoding='utf-8').read()
setup(
name="python-mimeparse",