summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README10
-rwxr-xr-xmimeparse_test.py1
2 files changed, 9 insertions, 2 deletions
diff --git a/README b/README
index d5c925d..ea9d942 100644
--- a/README
+++ b/README
@@ -21,4 +21,12 @@ Python
The Python tests require Python 2.6.
Run the tests by typing:
-python mimeparse_test.py \ No newline at end of file
+python mimeparse_test.py
+
+Make sure the package conforms to the PEP8 style guide:
+pep8 --statistics --show-source --ignore=E501 --exclude=venv .
+
+Check the code for simple warnings and errors:
+pyflakes mimeparse.py mimeparse_test.py setup.py
+
+You may need to install pep8 and pyflakes via pip to run these 2 tests.
diff --git a/mimeparse_test.py b/mimeparse_test.py
index e9ef311..6d00238 100755
--- a/mimeparse_test.py
+++ b/mimeparse_test.py
@@ -8,7 +8,6 @@ of PyUnitTestCases. Then it uses PyUnit to run them and report their status.
import json
import mimeparse
import unittest
-from functools import partial
__version__ = "0.1"