summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4d395ea..e0ba146 100755
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,8 @@ def get_version(filename):
return re.search("__version__ = ['\"]([^'\"]+)['\"]", contents).group(1)
version = get_version('mimeparse.py')
+if not version:
+ raise RuntimeError('Cannot find version information')
def read(fname):
@@ -22,6 +24,7 @@ def read(fname):
with codecs.open(path, encoding='utf-8') as fp:
return fp.read()
+
setup(
name="python-mimeparse",
py_modules=["mimeparse"],