summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 7 insertions, 9 deletions
diff --git a/tox.ini b/tox.ini
index 62c1338..efdf5ff 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,8 +1,9 @@
[tox]
-envlist = py35,py34,py32,py27,pypy,pypy3,pep8,pyflakes
+envlist = py35,py34,py32,py27,pypy,pypy3,flake8
[testenv]
-commands = ./mimeparse_test.py
+commands = python --version
+ ./mimeparse_test.py
[testenv:py35]
basepython = python3.5
@@ -22,10 +23,7 @@ basepython = pypy
[testenv:pypy3]
basepython = pypy3
-[testenv:pep8]
-deps = pep8
-commands = pep8 --statistics --show-source --ignore=E501 --exclude=.venv,.tox,*egg .
-
-[testenv:pyflakes]
-deps = pyflakes
-commands = pyflakes mimeparse.py mimeparse_test.py setup.py
+[testenv:flake8]
+deps = flake8
+ flake8-import-order
+commands = flake8 --statistics --show-source --ignore=E501 --exclude=.venv,.tox,*egg,*.egg-info,build,dist .