summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2014-06-30 23:17:28 +0000
committer <>2014-10-24 11:03:41 +0000
commit9817ec3e47bca8fba9a7cac56d785e9d644f7473 (patch)
tree2eddc46197f66e1629dcdf01bf0cb543c729920c /setup.py
downloadpython-rfc3986-9817ec3e47bca8fba9a7cac56d785e9d644f7473.tar.gz
Imported from /home/lorry/working-area/delta_python-packages_python-rfc3986/rfc3986-0.2.0.tar.gz.HEADrfc3986-0.2.0master
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..28a4e26
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,53 @@
+#!/usr/bin/env python
+
+import os
+import sys
+
+import rfc3986
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+if sys.argv[-1] == 'publish':
+ os.system('python setup.py bdist_wheel sdist upload')
+ sys.exit()
+
+packages = [
+ 'rfc3986',
+]
+
+with open('README.rst') as f:
+ readme = f.read()
+
+with open('HISTORY.rst') as f:
+ history = f.read()
+
+setup(
+ name='rfc3986',
+ version=rfc3986.__version__,
+ description='Validating URI References per RFC 3986',
+ long_description=readme + '\n\n' + history,
+ author='Ian Cordasco',
+ author_email='ian.cordasco@rackspace.com',
+ url='https://rfc3986.rtfd.org',
+ packages=packages,
+ package_data={'': ['LICENSE']},
+ package_dir={'requests': 'requests'},
+ include_package_data=True,
+ license='Apache 2.0',
+ zip_safe=False,
+ classifiers=(
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ ),
+)