diff options
author | Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> | 2016-10-01 17:41:13 +0200 |
---|---|---|
committer | Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> | 2016-10-01 17:45:09 +0200 |
commit | 84fcfc05e527e43f6a2fa756159d374a7eab8618 (patch) | |
tree | 5e0cf50edea0634860a47644c6bc6be81cff945e | |
parent | 911591a1188e03942e60f2ab1abf91562904f49e (diff) | |
download | python-systemd-84fcfc05e527e43f6a2fa756159d374a7eab8618.tar.gz |
setup.py: make build fail if undeclared symbols are used
This will detect cases where the autoconfig based on version is wrong.
Debian bug #839224.
-rw-r--r-- | setup.py | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -46,24 +46,29 @@ defines = {'define_macros':[('PACKAGE_VERSION', '"{}"'.format(version))]} _journal = Extension('systemd/_journal', sources = ['systemd/_journal.c', 'systemd/pyutil.c'], + extra_compile_args=['-Werror=implicit-function-declaration'], **lib('libsystemd', 'libsystemd-journal', **defines)) _reader = Extension('systemd/_reader', sources = ['systemd/_reader.c', 'systemd/pyutil.c', 'systemd/strv.c'], + extra_compile_args=['-Werror=implicit-function-declaration'], **lib('libsystemd', 'libsystemd-journal', **defines)) _daemon = Extension('systemd/_daemon', sources = ['systemd/_daemon.c', 'systemd/pyutil.c'], + extra_compile_args=['-Werror=implicit-function-declaration'], **lib('libsystemd', 'libsystemd-daemon', **defines)) id128 = Extension('systemd/id128', sources = ['systemd/id128.c', 'systemd/pyutil.c'], + extra_compile_args=['-Werror=implicit-function-declaration'], **lib('libsystemd', 'libsystemd-id128', **defines)) login = Extension('systemd/login', sources = ['systemd/login.c', 'systemd/pyutil.c', 'systemd/strv.c'], + extra_compile_args=['-Werror=implicit-function-declaration'], **lib('libsystemd', 'libsystemd-login', **defines)) setup (name = 'systemd-python', version = version, |