summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-10-27 00:12:00 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-10-27 00:12:11 -0400
commitd31bfc3ba6f3ec5b6d9af355e9b0dde6bd1ffa76 (patch)
tree3639ed980fa78aafea39be1e3bd87187689f9378
parentc1c55294f197675a32f91effdc220fcaead91ad3 (diff)
downloadpython-systemd-d31bfc3ba6f3ec5b6d9af355e9b0dde6bd1ffa76.tar.gz
build-sys: add utility target to run tests
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8c3b902..e17e1bd 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@ SPHINX_BUILD = sphinx-build
ETAGS = etags
INCLUDE_DIR = /usr/include/
VERSION := $(shell $(PYTHON) setup.py --version)
+TESTFLAGS = -v
define buildscript
import sys,sysconfig
@@ -34,6 +35,9 @@ sphinx-%: build
PYTHONPATH=$(builddir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) docs build/docs
@echo Output has been generated in build/docs
+check: build
+ $(PYTHON) -m py.test $(builddir) docs $(TESTFLAGS)
+
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+