summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-10-27 00:02:52 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-10-27 00:07:18 -0400
commit3217d17d0cd8a1bff007b063ed787905e6d0d7ba (patch)
tree0f6a58be520c94f4193abf67003c59839c99d838
parenta947f32b310005c4cc3e65a39504e0b32fb66bab (diff)
downloadpython-systemd-3217d17d0cd8a1bff007b063ed787905e6d0d7ba.tar.gz
build-sys: include tests in installation
This also allows tests to be run against he build directory: $ py.test-2.7 -v build/lib.linux-x86_64-2.7 docs $ py.test-3.4 -v build/lib.linux-x86_64-3.4 docs
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d18090b..3485b34 100644
--- a/setup.py
+++ b/setup.py
@@ -95,7 +95,8 @@ setup (name = 'python-systemd',
'Topic :: System :: Logging',
'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)',
],
- py_modules = ['systemd.journal', 'systemd.daemon'],
+ py_modules = ['systemd.journal', 'systemd.daemon',
+ 'systemd.test.test_daemon', 'systemd.test.test_journal'],
ext_modules = [_journal,
_reader,
_daemon,