summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-19 11:22:10 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-03-19 13:17:13 -0400
commit3f9386a4359219991dba3fd5f770f348270e178b (patch)
tree41d6f08ca791a5ff7fcfef088e1837d02fe80a3b
parentae08cbfe1101c452bcd98726bcfbafbc1a5e5b9f (diff)
downloadpython-systemd-3f9386a4359219991dba3fd5f770f348270e178b.tar.gz
Makefile: add "doc" target for convenience
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e4019d0..b34f251 100644
--- a/Makefile
+++ b/Makefile
@@ -55,6 +55,8 @@ sphinx-%: build
PYTHONPATH=$(builddir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) docs build/$*
@echo Output has been generated in build/$*
+doc: sphinx-html
+
check: build
(cd $(builddir) && $(PYTHON) -m pytest . ../../docs $(TESTFLAGS))
@@ -68,4 +70,4 @@ upload: dist/systemd-python-$(VERSION).tar.gz dist/systemd-python-$(VERSION).tar
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+
-.PHONY: build install dist sign upload clean distclean TAGS doc-sync
+.PHONY: build install dist sign upload clean distclean TAGS doc doc-sync